I apologize for not having any idea where to start on this.  I am not
whining for someone to fix something, merely reporting an odd behavior
that I have now seen on multiple machines in cae it means something to

I am tracking current almost daily on three machines.  Starting
yesterday I managed to get one box that refused to go into multiuser
mode it would run the rc script and then hang somewhere executing the
scripts in /usr/local/etc/rc.d.  If I Ctrl-C'ed it - it would come up
in the single-user mode shell.  no login prompt, just the shell.  I
could however telnet into the thing most things seemed to work.

In this state it had hung without starting INN - so I su'ed and tried
to start it.  INN starts, but I end up at a prompt with a uid of news!
If I exit that, INN dies.

I do a ps -ax and I get some corrupt lines:

  471  p0  Is     0:00.07 -csh (csh)
  473  p0  I      0:00.01 su -m
  474  p0  S      0:00.04 \M-[\M-!\^D\b\M-X\M-!\^D\b (csh)
12673  p0  R+     0:00.00 ps ax
  466  v0  Is+    0:00.01 /usr/libexec/getty Pc ttyv0

In troubleshooting this I went back to an older kernel and the problem
persists.  Change back to an old world and it's gone.  Tried the
new kernel with old world and it also seems to work fine.  So the
problem seems to be somewhere in the libs or userland.

Now I went and looked at some other systems rebuilt yesterday evening
and today and while they still work I see the same sort of corruption
as above in the ps output - but no other apparent side effects.

The corrupted line shows up in many different places and users, and
the exact contents vary, but there's always a "(csh)" at the end.

Dave Cornejo @ Dogwood Media, Fremont, California (also [EMAIL PROTECTED])
  "There aren't any monkeys chasing us..." - Xochi

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to