linux_base-7 (And most likely other ports as well) seems to be broken after zlib 1.1.4
was committed to -current. Zlib was made with fresh source from today (28.3) and rpm

===>  Installing for linux_base-7.1_2
kern.fallback_elf_brand: 3 -> 3
Segmentation fault - core dumped
*** Error code 139

Not particulary promising when you look at the core backtrace from rpm...

#0  0x8090a3f in inflate_codes (s=0x8150380, z=0x8154b00, r=0)
at /usr/src/lib/libz/infcodes.c:203
203           while (f < s->window)             /* modulo window size-"while" instead
*/ (gdb) bt
#0  0x8090a3f in inflate_codes (s=0x8150380, z=0x8154b00, r=0)
at /usr/src/lib/libz/infcodes.c:203
#1  0x808e49f in inflate_blocks (s=0x8150380, z=0x8154b00, r=0)
at /usr/src/lib/libz/infblock.c:343
#2  0x808bec3 in inflate (z=0x8154b00, f=0) at /usr/src/lib/libz/inflate.c:224 #3
0x808b220 in gzread (file=0x8154b00, buf=0xbfbdc1f4, len=110)
at /usr/src/lib/libz/gzio.c:411
#4  0x80739e6 in gzdRead (cookie=0x816b200,

00410000000d0000005e0000001400000000$ýW\005\b", count=110) at rpmio.c:2230 #5
0x8074e9a in Fread (buf=0xbfbdc1f4, size=1, nmemb=110, fd=0x816b200) at rpmio.c:2537 #6
 0x8059cd3 in getNextHeader (cfd=0x816b200, chPtr=0xbfbdc2fc) at cpio.c:69 #7
0x805ac57 in cpioInstallArchive (cfd=0x816b200, mappings=0xbfbdc35c, numMappings=5985,
cb=0x8063910 <callback>,
    cbData=0xbfbff4ac, failedFile=0xbfbff4a4) at cpio.c:551
#8  0x8063bd9 in installArchive (fd=0x8126300, files=0x8345000, fileCount=5985,
notify=0x806e860 <showProgress>,
    notifyData=0x24, pkgKey=0xbfbffc01, h=0x8158300, specFile=0x0,
at install.c:370
#9  0x8064b07 in installBinaryPackage (rootdir=0x8239060 "/compat/linux", db=0x8130680,
fd=0x8126300, h=0x8158300, flags=0,
    notify=0x806e860 <showProgress>, notifyData=0x24, pkgKey=0xbfbffc01,
actions=0x8164000, sharedList=0x0, scriptFd=0x0)
    at install.c:870
#10 0x8082059 in rpmRunTransactions (ts=0x8124680, notify=0x806e860 <showProgress>,
notifyData=0x24, okProbs=0x0,
    newProbs=0xbfbff8b4, transFlags=0, ignoreSet=7) at transaction.c:1652
#11 0x806f446 in rpmInstall (rootdir=0x81211c0 "/compat/linux", fileArgv=0x8123000,
transFlags=0, interfaceFlags=36,
    probFilter=7, relocations=0x0) at rpminstall.c:377
#12 0x804c8cb in main (argc=11, argv=0xbfbffa98) at rpm.c:1395
#13 0x8048135 in _start (arguments=0xbfbffba0 "rpm") at /usr/src/lib/csu/i386-

This problem affects linux_base as well, but it breaks a little bit later:

===>  Installing for linux_base-6.1_1
Segmentation fault - core dumped
*** Error code 139

Also, take a look at the update done to infcodes.c from version 1.1.3 -> 1.1.4:
Looks suspeciously familiar?

Am I crazy and is this a real problem or is it just my system?

-- Anders Nor Berle

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to