I just tried the Developers Preview 1, and was really looking forwards to
the new cardbus support. But while booting I now get the following (ACPI
disabled, funny messages show up if enabled):

pccbb0: <TI1225 PCI-CardBus Bridge> at device 10.0 on pci0
cardbus0: <CardBus bus> on pccbb0
pccard0: <16-bit PCCard bus> on pccbb0
pci_cfgintr_linked: linked (62) to hard routed irq -1
pci_cfgintr: 0:10 INTA routed to irq -1
pccbb: Unable to map IRQ...
panic: resource_list_release: can't find resource
Stopped at     Debugger+0x40: xorl    %eax,%eax


This does not happen when using OLDCARD, but OLDCARD is pretty useless,
since my network device is CardBus.

CardBus support works perfectly on Windows and Linux.
(I inspected the Linux code. There is a special section dealing with bogus
PCI IRQ configurations.)

The NetBSD guys also screwed it up in their system (i tried it once) there
I got a similar message. They also had code to work around this problem,
but it simply did not work.

So, it would be nice if there was some hint or workaround. I am really
sick of the Linux installation on my Notebook and really want FreeBSD
I am too unexperienced with PCI IRQ routing and stuff, so I can't fix it
myself (I don't have time either.)

I hope there is a soulution to this problem.


Klaus Leibrandt

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to