On Sat, May 11, 2002 at 01:33:09PM -0700, David O'Brien wrote:

> @@ -87,17 +113,17 @@
>  # presence of a CPU feature.
>  .if ${MACHINE_ARCH} == "i386"
> -. if ${CPUTYPE} == "k7"
> -MACHINE_CPU = k7 3dnow mmx k6 k5 i586 i486 i386
> +. if ${CPUTYPE} == "athlon"
> +MACHINE_CPU = athlon 3dnow mmx k6 k5 i586 i486 i386

This one should probably be left as k7; MACHINE_CPU is the variable
that is supposed to be used by applications to selectively enable
optimizations (so changing the name of the keyword from k7 to athlon
would break selection).  On the other hand, there probably aren't any
applications which have athlon-specific optimizations yet.


Attachment: msg38206/pgp00000.pgp
Description: PGP signature

Reply via email to