On Sat, May 11, 2002 at 02:17:40PM -0700, David O'Brien wrote:
> On Sat, May 11, 2002 at 01:46:32PM -0700, Kris Kennaway wrote:
> > On Sat, May 11, 2002 at 01:33:09PM -0700, David O'Brien wrote:
> > 
> > > @@ -87,17 +113,17 @@
> > >  # presence of a CPU feature.
> > >  
> > >  .if ${MACHINE_ARCH} == "i386"
> > > -. if ${CPUTYPE} == "k7"
> > > -MACHINE_CPU = k7 3dnow mmx k6 k5 i586 i486 i386
> > > +. if ${CPUTYPE} == "athlon"
> > > +MACHINE_CPU = athlon 3dnow mmx k6 k5 i586 i486 i386
> > 
> > This one should probably be left as k7; MACHINE_CPU is the variable
> > that is supposed to be used by applications to selectively enable
> > optimizations (so changing the name of the keyword from k7 to athlon
> > would break selection).
> 
> Should we have "k7 athlon duron" there?

MACHINE_CPU is a list of chipset features supported by the CPU.
Unless there's any difference in the chipset features implemented by
athlon and duron (which cannot be described better by specific labels
like 3dnow or mmx), then there should just be one token to identify
them.

Having both "k7" and "athlon" would be pointless too since the
application makefile is supposed to do things like

.if ${MACHINE_CPU:M3dnow}
        [enable 3dnow optimizations]
.endif

and if there are two "competing" tokens to identify the athlon CPU
instruction set then there's confusion about how to test for it.

Kris


Attachment: msg38218/pgp00000.pgp
Description: PGP signature

Reply via email to