On Tue, May 14, 2002 at 08:45:59AM +0200, Riccardo Torrini wrote:
> On 14-May-2002 (06:21:18/GMT) Ruslan Ermilov wrote:
> > I'm still unsure about the name; I'd have liked to rename it to
> > "includesinstall" but that is too long.
> Ummmm, buildworld, installworld, buildkernel, installkernel...
> It would be: buildinclude{s}, installinclude{s} just to be simmetric  :)
> And is only one (or two) character longer than installkernel...
Then "all" should similarly be renamed to "build".  I like the idea
of consistent naming.  It's a pity we don't have synonyms in make(1).

build: buildprogram buildscripts buildfiles buildmanpages buildincludes
Then s/build/install/g.

"build" should probably be left as "all" for compatibility, I'm not sure.
Then we could say that we reserve target names "all.*" and "install.*",
to avoid possible clashes.

I will see if I can implement something like that in a long term.

Ruslan Ermilov          Sysadmin and DBA,
[EMAIL PROTECTED]           Sunbay Software AG,
[EMAIL PROTECTED]          FreeBSD committer,
+380.652.512.251        Simferopol, Ukraine

http://www.FreeBSD.org  The Power To Serve
http://www.oracle.com   Enabling The Information Age

Attachment: msg38309/pgp00000.pgp
Description: PGP signature

Reply via email to