On Tue, 2002-05-14 at 05:34, Alexander Leidinger wrote:
> On  7 Mai, Benjamin Lewis wrote:
> > Now, on to the problem.  I use amanda for backups, and since mid-April
> > I've been seeing items like the following in the backup report:

[edited for brevity]

> >     |   DUMP: slave couldn't reopen disk: Interrupted system call
> >     |   DUMP: The ENTIRE dump is aborted.
> >     sendbackup: error [/sbin/dump returned 3]
> >     \--------
> Try the attached patch. I also have a similar patch for restore. I don't
> like the patch, I think I should use SA_RESTART with sigaction(), so
> think about this patch as a proof of concept (if it solves your
> problem).

For those that are interested and those that come across this in the
archives, I would like to thank Alexander Leidinger very much.  The
patch he sent me seems to have solved the problem illustrated above.

I ran several test dumps immediately after rebuilding /sbin/dump, and
it was very promising in that no errors were reported.  Prior to the
patch, I was consistently able to generate an error within 3 attempts.

Since then, Amanda has run and there were no reported issues with the
run.  Last night was the first entirely successful run in a long time.
I pulled all of the dumps back from tape, restored them to a secondary
location, and used "cmp" to compare them to the originals.  The only
differences found were the expected logfiles and other ephemeral data.

In short, the patch seems to have completely solved my problem

My thanks to M. Leidinger,


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to