I have trouble that f77 cannot find -lfrtbegin which gcc-3.1 has.

For example, the program shown below cannot be linked.

      program killw2k
      write(*,*) '\t\b\b'

Verbose output is like this.

$ f77 -v killw2k.f
Driving: f77 -v killw2k.f -lfrtbegin -lg2c -lm
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.1 [FreeBSD] 20020509 (prerelease)
 /usr/libexec/f771 killw2k.f -quiet -dumpbase killw2k.f -version -o 
GNU F77 version 3.1 [FreeBSD] 20020509 (prerelease) (i386-undermydesk-freebsd)
        compiled by GNU C version 3.1 [FreeBSD] 20020509 (prerelease).
 /usr/libexec/elf/as -v -o /home/nakaji/tmp/ccSLtLlz.o /home/nakaji/tmp/ccCXNucA.s
GNU assembler version 2.12.0 [FreeBSD] 2002-04-10 (i386-obrien-freebsd5.0) using BFD 
version 2.12.0 [FreeBSD] 2002-04-10
 /usr/libexec/elf/ld -V -dynamic-linker /usr/libexec/ld-elf.so.1 /usr/lib/crt1.o 
/usr/lib/crti.o /usr/lib/crtbegin.o -L/usr/lib /home/nakaji/tmp/ccSLtLlz.o -lfrtbegin 
-lg2c -lm -lgcc -lc -lgcc /usr/lib/crtend.o /usr/lib/crtn.o
GNU ld version 2.12.0 [FreeBSD] 2002-04-10
  Supported emulations:
/usr/libexec/elf/ld: cannot find -lfrtbegin

The kernel is built yesterday.

$ uname -a
FreeBSD boggy.acest.tutrp.tut.ac.jp 5.0-CURRENT FreeBSD 5.0-CURRENT #4:
Wed May 22 13:08:08 JST 2002
[EMAIL PROTECTED]:/usr/obj/usr/src/sys/NAKAJI  i386
NAKAJI Hiroyuki

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to