On Mon, Mar 17, 2003 at 01:07:53PM -0800, David O'Brien wrote:
> On Mon, Mar 17, 2003 at 12:43:19PM -0800, Crist J. Clark wrote:
> > On Mon, Mar 17, 2003 at 09:11:12AM -0800, David O'Brien wrote:
> > > On Mon, Mar 17, 2003 at 12:28:34AM -0800, Crist J. Clark wrote:
> > > > +kldxref_start () {
> > > > +       if [ -z "$kldxref_module_path" ]; then
> > > > +               MODULE_PATHS=`sysctl -n kern.module_path`
> > > > +       else
> > > > +               MODULE_PATHS="$kldxref_module_path"
> > > > +       fi
> > > 
> > > Please change the logic to positive logic:
> > > 
> > >     if [ -n "$kldxref_module_path" ]; then
> > >     MODULE_PATHS="$kldxref_module_path"
> > >     else
> > >     MODULE_PATHS=`sysctl -n kern.module_path`
> > >     fi
> > 
> > Is there a technical reason for that or is it just a "style" issue?
> 
> Style, easier to read out loud, easier to understand w/o having to think.
> Just like this is hard to "read".  It certainly doesn't do what one reads
> out loud: "if not string compaire equal".
> 
>     if (!strcmp(a,b) {
>         printf("same\n");
>     }

I don't see what that code snipit has to do with the script (but I am
in the camp that would go ahead and waste the four bytes of source
code to write that as (strcmp(a, b) == 0)).

I _did_ write the original script the way I was thinking/would say it,

  "If $kldxref_module_path is empty, use the sysctl(8), otherwise, use
   its contents."

I guess I was thinking of '-z' as a positive, "is empty," rather than
a negative, "is not filled."

But whatever. I've changed it to the "positive" in my repository. I'll
commit the latest version later and everyone can make there own
fixes/additions/changes/PRs.
-- 
Crist J. Clark                     |     [EMAIL PROTECTED]
                                   |     [EMAIL PROTECTED]
http://people.freebsd.org/~cjc/    |     [EMAIL PROTECTED]

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-current" in the body of the message

Reply via email to