You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: ma...@freebsd.org
Ident:          $FreeBSD: branches/2014Q3/www/oops/Makefile 359764 2014-06-29 
13:43:21Z marck $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-07-02_22h15m29s/logs/oops-1.5.24_12.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-quarterly/2014-07-02_22h15m29s
Log:

====>> Building www/oops
build started at Thu Jul  3 10:33:06 UTC 2014
port directory: /usr/ports/www/oops
building for: FreeBSD 10i386-quarterly-job-19 10.0-RELEASE-p3 FreeBSD 
10.0-RELEASE-p3 i386
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: branches/2014Q3/www/oops/Makefile 359764 
2014-06-29 13:43:21Z marck $
Poudriere version: 3.1-pre
Host OSVERSION: 1100022
Jail OSVERSION: 1000510

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000510
UNAME_v=FreeBSD 10.0-RELEASE-p3
UNAME_r=10.0-RELEASE-p3
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/10i386-quarterly/ref
PKG_EXT=txz
tpid=31180
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=oops-1.5.24_12
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/10i386-quarterly/ref/poudriere/pool
MASTERNAME=10i386-quarterly
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for oops-1.5.24_12:
     MYSQL=off: MySQL auth support
     PCRE=off: Use Perl Compatible Regular Expressions
     PGSQL=off: PostgreSQL auth support
====> DB storage: you can only select none or one of them
     GIGABASE=on: GigaBase storage
     DB4=off: Berkeley DB v4 storage
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--sbindir=/usr/local/sbin  --sysconfdir=/usr/local/etc/oops  
--localstatedir=/var/run/oops  --libdir=/usr/local/libexec/oops  
--enable-oops-user=oops  --enable-large-files  --with-regexp=system 
--without-DB --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/www/oops/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/oops/work  
HOME=/wrkdirs/usr/ports/www/oops/work TMPDIR="/tmp" 
XDG_DATA_HOME=/wrkdirs/usr/ports/www/oops/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/oops/work  
HOME=/wrkdirs/usr/ports/www/oops/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh  AUTOCONF=/usr/local/bin/autoconf-2.69  
AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69  
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/www/oops/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/oops/work  
HOME=/wrkdirs/usr/ports/www/oops/work TMPDIR="/tmp" 
XDG_DATA_HOME=/wrkdirs/usr/ports/www/oops/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/www/oops/work  
HOME=/wrkdirs/usr/ports/www/oops/work TMPDIR="/tmp" NO_PIE=yes SHELL=/bin/sh 
NO_LINT=YES  AUTOCONF=/usr/local/bin/autoconf-2.69  
AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69  
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fPIC -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fPIC -fno-strict-aliasing -fPIC"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  
 BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/oops"
EXAMPLESDIR="share/examples/oops"
DATADIR="share/oops"
WWWDIR="www/oops"
ETCDIR="etc/oops"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/oops
DOCSDIR=/usr/local/share/doc/oops
EXAMPLESDIR=/usr/local/share/examples/oops
WWWDIR=/usr/local/www/oops
ETCDIR=/usr/local/etc/oops
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for oops-1.5.24_12
=======================<phase: check-sanity   >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Development stops long ago, domain has been expired.

It is scheduled to be removed on or after 2014-08-31.

===========================================================================
=======================<phase: pkg-depends    >============================
===>   oops-1.5.24_12 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_3.txz
Installing pkg-1.2.7_3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of oops-1.5.24_12
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Development stops long ago, domain has been expired.

It is scheduled to be removed on or after 2014-08-31.

===> Fetching all distfiles required by oops-1.5.24_12 for building
===========================================================================
=======================<phase: checksum       >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Development stops long ago, domain has been expired.

It is scheduled to be removed on or after 2014-08-31.

===> Fetching all distfiles required by oops-1.5.24_12 for building
=> SHA256 Checksum OK for oops-1.5.24.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Development stops long ago, domain has been expired.

It is scheduled to be removed on or after 2014-08-31.

===> Fetching all distfiles required by oops-1.5.24_12 for building
===>  Extracting for oops-1.5.24_12
===>   NOTICE:

This port is deprecated; you may wish to reconsider installing it:

Development stops long ago, domain has been expired.

It is scheduled to be removed on or after 2014-08-31.

===> Fetching all distfiles required by oops-1.5.24_12 for building
=> SHA256 Checksum OK for oops-1.5.24.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for oops-1.5.24_12
===>  Applying FreeBSD patches for oops-1.5.24_12
===========================================================================
=======================<phase: build-depends  >============================
===>   oops-1.5.24_12 depends on executable: gawk - not found
===>    Verifying install for gawk in /usr/ports/lang/gawk
===>   Installing existing package /packages/All/gawk-4.1.1_1.txz
Installing gawk-4.1.1_1...Installing gettext-0.18.3.1_1...Installing 
indexinfo-0.2... done
 done
Installing libsigsegv-2.10... done
 done
====
Note that the stackoverflow handling functions of this library need
procfs mounted on /proc.
====
===>   Returning to build of oops-1.5.24_12
===>   oops-1.5.24_12 depends on file: /usr/local/bin/autoconf-2.69 - not found
===>    Verifying install for /usr/local/bin/autoconf-2.69 in 
/usr/ports/devel/autoconf
===>   Installing existing package /packages/All/autoconf-2.69.txz
Installing autoconf-2.69...Installing autoconf-wrapper-20131203... done
Installing m4-1.4.17_1,1... done
<snip>
===========================================================================
=======================<phase: lib-depends    >============================
===>   oops-1.5.24_12 depends on shared library: gigabase_r.2 - not found
===>    Verifying install for gigabase_r.2 in /usr/ports/databases/gigabase
===>   Installing existing package /packages/All/gigabase-3.91.txz
Installing gigabase-3.91...Installing gcc-4.7.3_1...Installing binutils-2.24... 
done
Installing gcc-ecj-4.5... done
Installing gmp-5.1.3_2... done
Installing mpc-1.0.2...Installing mpfr-3.1.2_2... done
 done
 done
 done
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc47

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
===>   Returning to build of oops-1.5.24_12
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for oops-1.5.24_12
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/www/oops/work/oops-1.5.24/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/www/oops/work/oops-1.5.24/configure
autoheader-2.69: WARNING: Using auxiliary files such as `acconfig.h', 
`config.h.bot'
autoheader-2.69: WARNING: and `config.h.top', to define templates for 
`config.h.in'
autoheader-2.69: WARNING: is deprecated and discouraged.
autoheader-2.69: 
autoheader-2.69: WARNING: Using the third argument of `AC_DEFINE' and
autoheader-2.69: WARNING: `AC_DEFINE_UNQUOTED' allows one to define a template 
without
autoheader-2.69: WARNING: `acconfig.h':
autoheader-2.69: 
autoheader-2.69: WARNING:   AC_DEFINE([NEED_FUNC_MAIN], 1,
autoheader-2.69:                [Define if a function `main' is needed.])
autoheader-2.69: 
autoheader-2.69: WARNING: More sophisticated templates can also be produced, 
see the
autoheader-2.69: WARNING: documentation.
configure: loading site script /usr/ports/Templates/config.site
checking build system type... i386-portbld-freebsd10.0
checking host system type... i386-portbld-freebsd10.0
checking target system type... i386-portbld-freebsd10.0
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking for flex... flex
checking lex output file root... lex.yy
checking lex library... -lfl
checking whether yytext is a pointer... yes
checking for bison... no
checking for byacc... byacc
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for minix/config.h... (cached) no
checking whether it is safe to define __EXTENSIONS__... yes
checking for inline... inline
checking whether we are using the GNU linker... yes
checking crypt.h usability... no
checking crypt.h presence... no
checking for crypt.h... no
checking for getopt.h... (cached) yes
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for strings.h... (cached) yes
checking for unistd.h... (cached) yes
checking for inttypes.h... (cached) yes
checking sys/inttypes.h usability... no
checking sys/inttypes.h presence... no
checking for sys/inttypes.h... no
checking netinet/ip_fil.h usability... no
checking netinet/ip_fil.h presence... yes
configure: WARNING: netinet/ip_fil.h: present but cannot be compiled
configure: WARNING: netinet/ip_fil.h:     check for missing prerequisite 
headers?
configure: WARNING: netinet/ip_fil.h: see the Autoconf documentation
configure: WARNING: netinet/ip_fil.h:     section "Present But Cannot Be 
Compiled"
configure: WARNING: netinet/ip_fil.h: proceeding with the compiler's result
checking for netinet/ip_fil.h... no
checking netinet/ip6.h usability... no
checking netinet/ip6.h presence... yes
configure: WARNING: netinet/ip6.h: present but cannot be compiled
configure: WARNING: netinet/ip6.h:     check for missing prerequisite headers?
configure: WARNING: netinet/ip6.h: see the Autoconf documentation
configure: WARNING: netinet/ip6.h:     section "Present But Cannot Be Compiled"
configure: WARNING: netinet/ip6.h: proceeding with the compiler's result
checking for netinet/ip6.h... no
checking ldap.h usability... no
checking ldap.h presence... no
checking for ldap.h... no
checking for pthread_create in -lpthread... yes
checking for dlopen in -ldl... no
checking for dlopen in -lc... yes
checking for yywrap in -lfl... yes
checking for crypt in -lcrypt... (cached) yes
checking for pam_end in -lpam... yes
checking for ldap_init in -lldap... no
checking for socklen_t... yes
checking for uint32_t... yes
checking for uint16_t... yes
checking for uint8_t... yes
checking for struct timespec... yes
checking for __tm_gmtoff__... no
checking flags to link shared objects....  -shared
checking for atoll... yes
checking for bzero... (cached) yes
checking for chroot... yes
checking for ctime_r... yes
checking for daemon... (cached) yes
checking for getdomainname... yes
checking for gethostbyname_r... yes
checking for getopt... (cached) yes
checking for getrlimit... (cached) yes
checking for getrusage... (cached) yes
checking for gmtime_r... yes
checking for localtime_r... yes
checking for poll... (cached) yes
checking for pread... (cached) yes
checking for pwrite... (cached) yes
checking for directio... no
checking for regcomp... yes
checking for setegid... (cached) yes
checking for snprintf... (cached) yes
checking for setrlimit... (cached) yes
checking for strcasestr... yes
checking for strerror_r... (cached) yes
checking for strtoll... (cached) yes
checking for strtok_r... yes
checking for snprintf... (cached) yes
checking for chown... /usr/sbin/chown
checking for libdb.a... no
checking for GigaBASE... -lgigabase_r
checking for libz... /usr/lib/libz.a
checking for -export-dynamic... yes
cc
-O2 -pipe -fPIC -fno-strict-aliasing -D_REENTRANT -DFREEBSD -D_THREAD_SAFE 
-DFD_SETSIZE=2048 -I. -DWITH_LARGE_FILES -export-dynamic
-lpthread -lfl -lfl -lpam -lcrypt -lstdc++

>>WARNING! YOU MUST CHECK THAT ALL FILES USED BY OOPS
>>ARE OWNED BY 'oops'. OTHERWISE, YOU WILL HAVE PROBLEMS.

configure: creating ./config.status
config.status: creating src/Makefile
config.status: creating src/modules/Makefile
config.status: creating src/oops.cfg
config.status: creating doc/oops.8
config.status: creating doc/oopsctl.8
config.status: creating src/config.h
===========================================================================
=======================<phase: build          >============================
===>  Building for oops-1.5.24_12
cd src; /usr/bin/make
cd modules; /usr/bin/make
cc -O2 -pipe -fPIC -fno-strict-aliasing -D_REENTRANT -DFREEBSD -D_THREAD_SAFE 
-DFD_SETSIZE=2048 -I. -DWITH_LARGE_FILES  -export-dynamic -DHAVE_CONFIG_H  
-shared  -c log_dummy.c
cc: warning: argument unused during compilation: '-e xport-dynamic'
cc: warning: argument unused during compilation: '-shared'
ld -shared  -o log_dummy.so log_dummy.o -lpthread -lfl -lfl -lpam  -lcrypt  
-lstdc++
ld: cannot find -lstdc++
*** Error code 1

Stop.
make[4]: stopped in /wrkdirs/usr/ports/www/oops/work/oops-1.5.24/src/modules
*** Error code 1

Stop.
make[3]: stopped in /wrkdirs/usr/ports/www/oops/work/oops-1.5.24/src
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/www/oops/work/oops-1.5.24
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/oops
*** Error code 1

Stop.
make: stopped in /usr/ports/www/oops
===>  Cleaning for oops-1.5.24_12
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to