Alejandro Pulver <[EMAIL PROTECTED]> writes:

> Hello.
> 
> I have upgraded my two identical (same CPU and motherboard) machines
> from FreeBSD 5.4 to 6.0 (cvs tag RELENG_6_0). Both of them have NVidia
> video cards. One has a GeForce 4 MX 440 w/AGP8X and the other a GeForce
> 6600.
> 
> I upgraded the system as described in the handbook and after that I
> rebuilt all the installed ports.
> 
> On the machine which has the GeForce 6600 everything works fine, but in
> the other machine there are two problems. Strangely in the machine that
> works fine the problem #1 happened only once.
> 
> 1) The first time the module was built (after upgrading to 6.0) when X
> started the system and screen frozen after 3 seconds. This didn't stop
> happening.
> 
> 2) After rebuilding the nvidia-driver port the system crashes (kernel
> panic) when it tries to load the kernel module to complete the
> installation of the port. It outputs the following messages (sometimes
> one and sometimes the other), followed by some information and kernel
> dump progress:
> 
> panic: softdep_setup_inomapdep: found inode
> [...]
> 
> Fatal trap 18: integer divide fault while in kernel mode
> [...]
> 
> The second error is the same as the one the working machine outputted
> when I tried to load the 5.4 kernel module into the 6.0 kernel.
> 
> If I copy the nvidia module from the working machine, problem #2 gets
> solved, but problem #1 happens.
> 
> What can I do?
> 
> If you need more information just ask.

On a system where I use that port, I upgrade it by just booting into
single-user mode, make sure the module is unloaded, and then upgrading
the module from there.
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to