Sorry for adding to my post before anyone responds, but:
I went ahead and installed from CD and have tried to talk to 
the net with the fully installed system up.  
During boot it finds the fwe0: card and appears to be happy,
but nothing talks.  When I do an 'ifconfig -a'  I get:

mtu 1500
      inet6 fe80::6:1bff"fe23"3833%fwe0 prefixlen 64 scopeid 0x1
      inet netmask 0xfff80000 broadcast
      ether 02:06:1b:23:38:33
      ch 1 dma 0

Followed by the lo0:   loopback stuff.

It looks a lot like the other machines I have plugged in to the
same switch that work except for the 'NEEDSGIANT' thing.

Am I right in assuming that it would not come up with this ifconfig
and the fwe stuff in the boot messages if it were not properly in
the kernel?

Are there any clues from this or where else can I look to see why
this thing doesn't talk to the net (but does in XP)?

I will appreciate any direction.  The only only google hits I have gotten 
that seem possibly relevant point to ubuntu and I can't seem to get to 
that server (from another machine that is working)- it times out.


> Hi,
> Is there any known problem with installing on a machine whose
> Ethernet is fwe0:  "Ethernet over Firewire" ?
> I am still trying to install on that IBM Z61t notebook.
> I get it all to appear to work - boot into sysinstall, slicing
> and partitioning, making install choices and setting up the network
> config stuff until it goes to look up the FreeBSD ftp host.   Then 
> it sets there until it times out.   
> This is with several mirrors and the main site.
> In the apparently related boot messages I see:
>  firewire0: <IEEE1394 (Firewire) bus> on fwohci0
>  fwe0: <Ethernet over Firewire> on firewire0
>  if_fwe0: Fake Ethernet address: 02:06:16:23:38:33
>  few0: Ethernet address: 02:06:16:23:38:33
>  fwe0: if_start running defferred for GIANT
> There are several <GIANT-LOCKED> messages, both before and after
> this fwe0 block of messages in the form of
>  uhci0: [GIANT-LOCKED]
>   etc for 0..3
>  ehci0: [GIANT-LOCKED]
>  atkbd: [GIANT-LOCKED]
>  psm0:  [GIANT-LOCKED]
> I presume these are normal because I see similar messages at boot
> time on machines that work fine.   But, I mention since there was
> a fwe0 message saying if_start is deffered for GIANT and I didn't
> see anywhere that it did anything like resume running.
> Anyway, I can't seem to install over ftp - with a fixed IP and hostname.
> I am quite sure I got things like gateway and nameserver correct - at
> least some of the times I have tried it.
> The NIC seems to work under XP (I am setting up a dual boot) since
> it is able to bring down some web stuff.  So, I believe the connection
> is good, speed, duplex matches, etc.
> The fwe man page says to add device firewire and device fwe to kernel
> config, but I presume the install kernel has them because it seems
> to recognize things OK - just not talk over it.
> So, any hints - is there something that needs enabling.
> ////jerry

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to