Hi all,

I ran into an unexpected problem today, when I tried to do
an in-place upgrade from FreeBSD 5.5 (actually RELENG_5) to
6-STABLE, following the procedure in /usr/src/UPDATING.

The buildworld and buildkernel went without a hitch, and
installkernel was fine, too.

When I rebooted to single-user, though, the fsck -p step
reported that my /usr partition was bad, and unfixable.
Something about not being able to find a good superblock, but I
didn't copy down the details.  The root partition was OK,
though, so I upgraded the mount to r/w and moved /boot/kernel
out of the way to /boot/kernel.6 and moved /boot/kernel.old back
to /boot/kernel, and rebooted back to multi-user in 5.5.  The
system claimed that /usr had not been unmounted properly, and
fired off a background fsck, which finished without finding any

I tried this twice (since fsck had given the /usr partition a
clean bill of health again), and it failed the same way the
second time.

Any thoughts on what could be going wrong?

This is a server, using ataraid to bind a pair of SATA drives
into a mirrored pair.  I had good success previously, with an
in-place upgrade of my workstation from RELENG_5 to RELENG_6,
but that wasn't using ataraid.


The top of dmesg.boot says:

FreeBSD 5.5-STABLE #1: Thu Sep 21 08:23:18 EST 2006
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/CORVUS
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (2992.52-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf43  Stepping = 3
  Hyperthreading: 2 logical CPUs
real memory  = 1065242624 (1015 MB)
avail memory = 1032859648 (985 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1

and the parts related to the disk controllers says:
atapci0: <Intel ICH6 UDMA100 controller> port 
0xffa0-0xffaf,0x376,0x170-0x177,0x3f6,0x1f0-0x1f7 at device 31.1 on pci0
ata0: channel #0 on atapci0
ata1: channel #1 on atapci0
atapci1: <Intel ICH6 SATA150 controller> port 
0xc400-0xc40f,0xc480-0xc483,0xc800-0xc807,0xc880-0xc883,0xcc00-0xcc07 irq 19 at 
device 31.2 on pci0
ata2: channel #0 on atapci1
ata3: channel #1 on atapci1

and the drives:
acd0: DVDROM <HL-DT-STDVD-ROM GDR8163B/0L23> at ata0-master PIO4
ad4: 76319MB <ST380817AS/3.42> [155061/16/63] at ata2-master SATA150
ad6: 76319MB <ST380817AS/3.42> [155061/16/63] at ata3-master SATA150
ar0: 76319MB <ATA RAID1 array> [9729/255/63] status: READY subdisks:
 disk0 READY on ad4 at ata2-master
 disk1 READY on ad6 at ata3-master

fdisk says:
******* Working on device /dev/ar0 *******
parameters extracted from in-core disklabel are:
cylinders=9729 heads=255 sectors/track=63 (16065 blks/cyl)

Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=9729 heads=255 sectors/track=63 (16065 blks/cyl)

Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
    start 63, size 156296322 (76316 Meg), flag 80 (active)
        beg: cyl 0/ head 1/ sector 1;
        end: cyl 1023/ head 254/ sector 63
The data for partition 2 is:
The data for partition 3 is:
The data for partition 4 is:

and bsdlabel ar0s1 says:
# /dev/ar0s1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  a:   524288        0    4.2BSD     2048 16384 32776
  b:  4126128   524288      swap
  c: 156296322        0    unused        0     0         # "raw" part, don't 
  d:   524288  4650416    4.2BSD     2048 16384 32776
  e:   524288  5174704    4.2BSD     2048 16384 32776
  f: 150597330  5698992    4.2BSD     2048 16384 28552

and /etc/fstab says:
# Device                Mountpoint      FStype  Options         Dump    Pass#
/dev/ar0s1b             none            swap    sw              0       0
/dev/ar0s1a             /               ufs     rw              1       1
/dev/ar0s1e             /tmp            ufs     rw              2       2
/dev/ar0s1f             /usr            ufs     rw              2       2
/dev/ar0s1d             /var            ufs     rw              2       2
/dev/acd0               /cdrom          cd9660  ro,noauto       0       0

and df says:
Filesystem  1K-blocks     Used    Avail Capacity  Mounted on
/dev/ar0s1a    253678    60566   172818    26%    /
devfs               1        1        0   100%    /dev
/dev/ar0s1e    253678    10266   223118     4%    /tmp
/dev/ar0s1f  72924656 23641878 43448806    35%    /usr
/dev/ar0s1d    253678    94556   138828    41%    /var

Would anything else be useful?

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to