As I was expecting, my post to freebsd-multimedia will not get me anywhere..
However, I'm not in the mood to give up this time..
Anyone here who has experienced making Leadtek Winfast 2000 XP RM work under
Just one quick answer, please....
Is this supported or not? :-(

I've been digging the list archive for quite some time now but still no

Someone got the same tv tuner and asked for help about a year ago..


I wonder what he/she has done with his tuner.. or did he just bought another
one which costs more.

You might want to check on the thread I started at freebsd-multimedia:

Thanks for the time..
I hope this is not cross posting.. i'm just trying to get some more help..

---------- Forwarded message ----------
From: Mark Jayson Alvarez <[EMAIL PROTECTED]>
Date: Nov 7, 2006 10:13 PM
Subject: Please don't tell me this is a "WIntuner" (my winmodem memories
keep hunting me...:-)


just purchased an ultra-cheap PCI TV Tuner, Leadtek WinFast TV2000 XP
RM and couldn't make it to work.

There were only 17 matches when you search the freebsd-multimedia
archive for "winfast"... been reading it over and over again and I
couldn't get any closer to my goal.

The box:


hw.bt848.slow_msp_audio: -1
hw.bt848.format: 0
hw.bt848.reverse_mute: -1
hw.bt848.tuner: 15
hw.bt848.card: 14

I tried using kbtv:

Hardware Info:

Bktr module:                   Loaded
Capture chip:                  BrookTree 878
Card name:                     Leadtek Winfast TV 2000 <sysctl:14>
-huh!? I thought it was 15 says bktr (4)
Tuner type:                     LG TP18PSB12P PAL  <sysctl:15> - as
according to this:

I'm leaving here in the Philippines
The tv tuner's surface doesn't really say anything about it's tuner
type. It just have a sticker with "Winfast TV2000 XP RM" and "NTSC"
selected on the checkbox..

The chipset is definitely a Conexant Fusion 878.

I tried xawtv... played with different values to no avail.

$xawtv -hwscan

This is xawtv-3.95, running on FreeBSD/i386 (6.2-PRERELEASE)
looking for available devices
port 57-88
   type : Xvideo, image scaler
   name : NV Video Blitter

/dev/bktr0: OK                          [ -device /dev/bktr0 ]
   type : bktr
   flags: overlay capture tuner

However, upon launching xawtv, I got these:

This is xawtv-3.95, running on FreeBSD/i386 (6.2-PRERELEASE)
Warning: Cannot convert string
"-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Xlib:  extension "GLX" missing on display ":0.0".

I removed bktr_load="YES" from /boot/loader.conf, rebooted the machine
sysctl were also gone it was detected as:

Leadtek Winfast TV 2000, Philips FR1236 NTSC FM tuner.

Perhaps you can get something from the verbose dmesg:

bktr_mem: memory holder loaded
pci0: driver added
found-> vendor=0x8086, dev=0x27da, revid=0x01
       bus=0, slot=31, func=3
       class=0c-05-00, hdrtype=0x00, mfdev=0
       cmdreg=0x0001, statreg=0x0280, cachelnsz=0 (dwords)
       lattimer=0x00 (0 ns), mingnt=0x00 (0 ns), maxlat=0x00 (0 ns)
       intpin=b, irq=23
pci0:31:3: reprobing on driver added
pci1: driver added
found-> vendor=0x109e, dev=0x036e, revid=0x11
       bus=1, slot=1, func=0
       class=04-00-00, hdrtype=0x00, mfdev=1
       cmdreg=0x0006, statreg=0x0290, cachelnsz=0 (dwords)
       lattimer=0x40 (1920 ns), mingnt=0x10 (4000 ns), maxlat=0x28 (10000
       intpin=a, irq=21
       powerspec 2  supports D0 D3  current D0
pci1:1:0: reprobing on driver added
bktr0: <BrookTree 878> mem 0xbfffe000-0xbfffefff irq 21 at device 1.0 on
bktr0: Reserved 0x1000 bytes for rid 0x10 type 3 at 0xbfffe000
ioapic0: routing intpin 21 (PCI IRQ 21) to vector 59
brooktree0: PCI bus latency is 64.
bktr0: buffer size 3555328, addr 0x1a000000
bktr0: GPIO is 0x003ff502
bktr0: subsystem 0x107d 0x6609
bktr0: Leadtek Winfast TV 2000, Philips FR1236 NTSC FM tuner.
found-> vendor=0x109e, dev=0x0878, revid=0x11
       bus=1, slot=1, func=1
       class=04-80-00, hdrtype=0x00, mfdev=1
       cmdreg=0x0006, statreg=0x0290, cachelnsz=0 (dwords)
lattimer=0x40 (1920 ns), mingnt=0x04 (1000 ns), maxlat=0xff (63750 ns)
       intpin=a, irq=21
       powerspec 2  supports D0 D3  current D0
pci1:1:1: reprobing on driver added
pci2: driver added
pci3: driver added
pci4: driver added
found-> vendor=0x10de, dev=0x0160, revid=0xa1
       bus=4, slot=0, func=0
       class=03-00-00, hdrtype=0x00, mfdev=0
       cmdreg=0x0007, statreg=0x0010, cachelnsz=4 (dwords)
       lattimer=0x00 (0 ns), mingnt=0x00 (0 ns), maxlat=0x00 (0 ns)
       intpin=a, irq=16
       powerspec 2  supports D0 D3  current D0
       MSI supports 1 message, 64 bit
pci4:0:0: reprobing on driver added
tun0: bpf attached

Is this some sort of like winmodem issue?? I noticed that a lot people
are complaining about not making their tv tuner to work. Any idea why?

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to