I am attempting to install FreeBSD 5.3 (because that's the latest distro I have CD's for) on a brand new system with a 80 G harddrive and 2 G RAM.

I boot from Disk 1 of the 5.3 disk set and choose to begin a standard installation. Next is the fdisk utility to partition the drive. The first thing I get is a message which states:

WARNING: A geometry of 155061/16/63 for ad0 is incorrect. Using a more likely geometry. If this geometry is incorrect or if you are unsure whether or not it's correct, please consult the hardware guide in the documentation submenu or use the (G)eometry command to change it now.

Even if I go to bios and use the values bios gives for the harddrive (38309/16/255) I still get the same message about incorrect geometry.

I can choose OK and get past this. I choose to devote the entire disk to FreeBSD, and install the FreeBSD boot manager. Next I need to partition my drive. The defaults won't do at all (this machine is to be a radius server & mail server and the default size of /var is too small). I chose 2000M for /, 4000M for swap (using 2 x RAM), 200M for /tmp, 20,000M for /usr and the remainder for /var.

Next I chose to install full sources, binaries & docs and to install the Ports collection.

I chose to install from CD then hit OK to start copying files but I get this error:

Unable to find device node for /dev/ad0s1b in /dev. The creation of file systems will be aborted.

ad0s1b is my swap partition. I changed the size of swap to 2000M thinking perhaps it was too large but I get the same error about unable to find device node.....

I've googled this but haven't found anything that helped me resolve this. Any body on this list know what I need to do to get FreeBSD installed on this drive?


Lisa Casey

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to