Hi

First of all i just went through the UPDATING instructions to upgrade my xorg 
to 7.2. It did not go very well because i can't finish the upgrade process. 
When i try to pkg_delete xorg-manpages it says they're required by the xorg-6.9 
port. 

Now as far as i can see everything i'm running is in /usr/local and X -version 
says 7.2 everywhere. But there are still some 6.9 ports left and i can't tell 
the difference between which ones i can delete and which ones i'm supposed to 
keep. 

 # pkg_info | grep xorg
 xorg-6.9.0          X.Org distribution metaport
 xorg-apps-7.2       X.org apps meta-port
 xorg-cf-files-1.0.2_2 X.org cf files for use with imake builds
 xorg-clients-6.9.0_2 X client programs and related files from X.Org
 xorg-docs-1.3,1     X.org documentation files
 xorg-documents-6.9.0 Documentation of X11 protocol and libraries from X.Org
 xorg-drivers-7.2    X.org drivers meta-port
 xorg-fonts-100dpi-6.9.0_1 X.Org 100dpi bitmap fonts
 xorg-fonts-7.2      X.org fonts meta-port
 xorg-fonts-75dpi-6.9.0_1 X.Org 75dpi bitmap fonts
 xorg-fonts-cyrillic-6.9.0_1 X.Org Cyrillic bitmap fonts
 xorg-fonts-miscbitmaps-6.9.0_1 X.Org miscellaneous bitmap fonts
 xorg-fonts-truetype-6.9.0 X.Org TrueType fonts
 xorg-fonts-type1-6.9.0 X.Org Type1 fonts
 xorg-fontserver-6.9.0_1 X font server from X.Org
 xorg-libraries-7.2_2 X.org libraries meta-port
 xorg-manpages-6.9.0 X.Org library manual pages
 xorg-nestserver-6.9.0 Nesting X server from X.Org
 xorg-printserver-6.9.0 X Print server from X.Org
 xorg-protos-7.2     X.org protos meta-port
 xorg-server-1.2.0_2,1 X.Org X server and related programs
 xorg-server-6.9.0_1 X.Org X server and related programs
 xorg-vfbserver-6.9.0 X virtual framebuffer server from X.Org

This is what it looks like after the upgrade. 

Also i'm not sure where to go for help with portupgrade but here seems like a 
good place to start. 

Now after i've run portupgrade -aP for the first time i tried to run it again 
just to see what it missed because i can't say the process progressed without 
errors, there were tons of them. Though this time i starts with a port i don't 
even have installed, gutenprint-base. 

It does not exist in /var/db/pkg, pkg_info doesn't find it and i can't make 
deinstall in the ports metadir because it's not installed. Yet portupgrade 
insists on 'upgrading' it by installing it for me. I'm thinking maybe it's a 
dependency of some newly upgraded port but i don't know how to make portupgrade 
show me that information. 
---


Med vänliga hälsningar 

Stefan Midjich (nocturnal)
~ http://swehack.se
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to