Thanks for the information Ben.  I have upgraded racoon and everything is
working fine.



----- Original Message -----
To: "Scott Penno" <[EMAIL PROTECTED]>
Sent: Thursday, January 30, 2003 9:25 AM
Subject: Re: Problems with IPSec

On Tue, Oct 01, 2002 at 02:41:24PM +0000, Scott Penno wrote:

> I have a FreeBSD box running -STABLE which has had IPSec working with
> hosts for quite some time without a problem.  I've just setup another
> FreeBSD box running 5.0-RC1 and am trying to establish a VPN tunnel but am
> not getting too far.  I'm using racoon and when attempting the negotiation
> with debugging enabled, the following message appears:
> 2003-01-20 12:00:23: ERROR: pfkey.c:207:pfkey_handler(): pfkey ADD failed:
> Invalid argument
> and the following message is logged via syslog:
> Jan 20 12:00:23 atlas kernel: key_mature: invalid AH key length 160
> allowed)

Tried rebuilding racoon? i had just upgraded a machine that was following
-STABLE and blowfish suddenly wasn't supported, and if i used aes or 3des
it complained like you've got. I did a "portupgrade -f racoon" suddenly all
worked fine again.. YMMV (:

[not subscribed to -questions either]

Ben. <ben @ mumble . org . uk>

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to