On Sep 5, 2007, at 3:07 AM, Ted Mittelstaedt wrote:



-----Original Message-----
From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] Behalf Of Kris Kennaway
Sent: Wednesday, September 05, 2007 1:57 AM
To: Chad Leigh -- Shire.Net LLC
Cc: User Questions
Subject: Re: no SMP without ACPI? (amd64)


Note that this may well be hardware related: without acpi you are only
using one CPU, etc, so if one of the others is bad it will only fail
when you have ACPI enabled -- even if ACPI itself is not to blame.


Easily testable by running that Other Operating system on the thing
which I would have expected Chad to have done.

Sorry to be MIA for the last day.

No, I did not test it with that OS which shall not be named. However, I did attempt to install Sol10 on it. Sol10 also relies on ACPI btw. Anyway, the same error happened a good way through the installation -- it rebooted itself during the high IO of installing the system onto the system array. Sol10 uses a 32bit kernel for the installation and I think, but am not sure, that it only activates 1 CPU core.

I do not think, however, that it is a bad CPU. I can boot the system with ACPI and activate all 4 CPU cores and I can run CPU intensive things, so far, as long as they do not generate lots of IO, and processes run fine on all 4 CPUs and will run for hours. However, if I do something that generates IOs, like a build world on the FreeBSD source, about 75% of the time it does not make it all the way through with the build. It takes me about 45min on this system to do a "make buildworld" and it usually will happen 10-30 minutes into the build. 25% of the time it will make it through 1 build world, and once or twice has made it through 2, but always fails in the same way on a subsequent retry of the build. (Ie, I just keep doing builds over and over until it fails, which is 75% of the time in the first build, 24% of the time in the second, and 1% of the time in the third, roughly speaking).

I also do not think it is the memory. For one, that would show up even with ACPI disabled, and 2, I ran multiple complete passes of the standalone memtest86 program without error.

I do not think it is thermally related as the temperature never got very high and I had additional fans temporarily blowing or I also stuck it directly over my A/C floor register with the A/C on blowing cold air directly at the intake of the system.

I monitored the Areca system while it was building and its temperatures never got anywhere near the limits Areca sets for their boards. (The Areca has its own ethernet port and I was directly attached to that from my powerbook during several tests when it failed).

This machine is now in production with only the 1 CPU core. I cannot do extensive testing but I can get pieces of info or do a reboot with ACPI if there are data items for me to grab if people want to take a look at what it is doing etc.

Thanks!
Chad

---
Chad Leigh -- Shire.Net LLC
Your Web App and Email hosting provider
chad at shire.net



_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to