I know where is your problem the burning device is always cd0

you must give the device node /dev/cd0

Take care!

Crist J. Clark wrote:
On Thu, Sep 13, 2007 at 01:21:09PM -0700, Predrag Punosevac wrote:
Make sure you add atapicam into your kernel it is not in generic! I had the same problem.

/etc/loader.conf   atapicam_load="YES"

I did a,

        # kldload /boot/kernel/atapicam.ko

And to reinitiallize the drive,

        # atacontrol detach ata1
        # atacontrol attach ata1

I got the same console message,

  acd0: detached
  (cd0:ata1:0:0:0): lost device
  (cd0:ata1:0:0:0): removing device entry
  atapicam1: detached
  stray irq15
  acd0: CDROM <CRD-8400B/1.06> at ata1-master UDMA33

And still get,

        # burncd -f /dev/acd0 -t -s 32 data ~cjc/hw.iso fixate
        burncd: ioctl(CDIOCSTART): Input/output error

Crist J. Clark wrote:
I just tried to burn a CD for the first time in a long time
on a machine. The burncd(8) command worked fine on this machine
in FreeBSD 5.x (or was it 4.x?), but now in 6.2, I get,

 # burncd -f /dev/acd0 -s 32 data hw.iso fixate
 burncd: ioctl(CDIOCSTART): Input/output error

Looking at the dmesg(1) from the last boot,

 # fgrep cd0 /var/run/dmesg.boot
 acd0: CDROM <CRD-8400B/1.06> at ata1-master UDMA33

Makes me think the system is not recognizing the device as CDRW,
only CDROM. I get this from atacontrol(8),

 # atacontrol info ata1
 Master: acd0 <CRD-8400B/1.06> ATA/ATAPI revision 0
 Slave:       no device present
 # atacontrol cap acd0

 Protocol              ATA/ATAPI revision 0
 device model          CRD-8400B
 serial number         1999/10/12
 firmware revision     1.06
 cylinders             0
 heads                 0
 sectors/track         0
lba supported lba48 not supported dma supported
 overlap not supported

 Feature                      Support  Enable    Value           Vendor
 write cache                    no       no
 read ahead                     no       no
 Tagged Command Queuing (TCQ)   no       no      0/0x00
 SMART                          no       no
 microcode download             no       no
 security                       no       no
 power management               no       no
 advanced power management      no       no      0/0x00
 automatic acoustic management  no       no      0/0x00  0/0x00

How can I restore burning capability?

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to