bob wrote:
My business has been using PHP for years. Mysql outputs to my browser, where I can print invoices, bills and any business statitic.

Suddenly, my browser started acting funny. I don't know how to use the repair disk to fix a problem, so I reinstalled FreeBSD-6.1. It still works the same except I can't get phpinfo() to display in the browser. I can do php -i, which displays several pages of PHP code. That means PHP is working. I don't use CGI or PHP scripts. If phpinfo() doesn't show up in my browser, I can't do anything.

The following is in /usr/local/etc/apache/httpd.conf:

LoadModule php5_module
AddModule mod_php5.c
DirectoryIndex index.php index.html
DirectoryIndex index.html
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

The httpd.error.log doesn't show any problems. Thre are 35 modules in /usr/local/libexec/apache including and httpd.exp. Php.ini is installed at /usr/local/lib

This time I installed mysql-5.1, apache-1.3 and PHP-5.1. I used "pkg_add -r" to install apache and mysql. Apache and mysql work excellent. I installed PHP from Both PHP4 and PHP5 would fail to load the phpinfo() file. I installed PHP-5.1 from the ports directory. Same problem. I ordered FreeBSD-6.1, before it was available. The FreeBSD Mall had it, but wasn't promoting it yet.

About 2 years ago when I first installed FreeBSD-6.1, I installed mysql-4.0, PHP-4 and apache-1.3 on FreeBSD-6.1. I used "pkg_add -r" to install apache and mysql and I downloaded PHP-4 from Everything worked, including PHP. Two years ago, was supplying any version of PHP including older versions of PHP-4. I installed older versions because they worked.
Now only supplies the latest version.

thanks for any help,

Not sure but whats your php info page look like? Think short tags are either off or on by default... do you have <?php .. ?> ?

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to