Hi all,

I use portsnap to keep the port tree of my FreeBSD 7 box up to date.
According to portaudit, which I run nightly, there is a problem with the
current version of libxml2. So, as usual, I run  "sudo portsnap fetch &&
sudo portsnap update", and then: 

$ cd /usr/ports/textproc/libxml2
$ sudo make deinstall
$ sudo make reinstall clean

But this last command results in an error:

===>  libxml2-2.6.32 has known vulnerabilities:
=> libxml2 -- two vulnerabilities.
   Reference:
<http://www.FreeBSD.org/ports/portaudit/d71da236-9a94-11dd-8f42-001c2514716c.html>
=> Please update your ports tree and try again.

It would appear that the port has not yet been updated. Is this some
temporary glitch? Otherwise, the approach I use is not very robust, since I
have now managed to deinstall a library upon which a dozen or so programs
depend. However, this is the first time this has happened.

Comments, suggestions most welcome.

Thanks.

-----
  Colin Brace
  Amsterdam
  http://lim.nl
-- 
View this message in context: 
http://www.nabble.com/updating-a-port-with-problems-%28libxml2%29-tp20028504p20028504.html
Sent from the freebsd-questions mailing list archive at Nabble.com.

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to