Colin Brace <[EMAIL PROTECTED]> writes:

> Hi all,
> I use portsnap to keep the port tree of my FreeBSD 7 box up to date.
> According to portaudit, which I run nightly, there is a problem with the
> current version of libxml2. So, as usual, I run  "sudo portsnap fetch &&
> sudo portsnap update", and then: 
> $ cd /usr/ports/textproc/libxml2
> $ sudo make deinstall
> $ sudo make reinstall clean
> But this last command results in an error:
> ===>  libxml2-2.6.32 has known vulnerabilities:
> => libxml2 -- two vulnerabilities.
>    Reference:
> <>
> => Please update your ports tree and try again.
> It would appear that the port has not yet been updated. Is this some
> temporary glitch? Otherwise, the approach I use is not very robust, since I
> have now managed to deinstall a library upon which a dozen or so programs
> depend. However, this is the first time this has happened.
> Comments, suggestions most welcome.

Hi Colin,

I hit  a similar difficulty with cups-base a few days ago.  Matthew
Seaman suggested this as a way of getting the dodgy port to install,
which I used because I *really* needed to print something:-

 portupgrade -m "DISABLE_VULNERABILITIES=yes" cups-base

Lo and behold, within 6 hours of my re-installing the vulnerable port,
the port was fixed and I upgraded to that


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to