Ivan Voras wrote:
PJ wrote:
I believe that my installation should be salvageable but I do not know
how to phrase my search question.
Here is the problem:
Apparently due to some connector problem in the computer one or some
files were damaged. I ran a regenerating program on the disk and all
sectors are readable.
How can I locate the problem files and repair or reinstall them without
damaging other files?

Try reading all the files on the drive, something like

find / -exec cat "{}" > /dev/null ";"

See if any files error out.

From trying to boot the system, it appears that the problem is related
to the login files: I boot to safe mode and get the logon prompt which
is not accepted. I then get to the single user mode and can read the

Boot to a single-user mode and see if /etc/passwd and /etc/master.passwd
are ok. If so, regenerate the databases (easiest way is to run vipw).

contents of the root (top or main) directory and subdirectories.
The command "df" returns "-70016" under Avail and "104%" under Capacity,
Mounted on / .

This doesn't necessarily mean there's an error. If you filled the file
system past its reserved space limit, it's normal to get negative
available bytes and over 100% usage. See also if you have a /lost+found

Or is it possible to reinstall the system from the installation CD? I
would like to avoid having to reinstall all the programs that run on
this local development server - Apache, Samba, Cups, php, pstgresql, etc.

It is possible, with care, to reinstall the system from the CD media,
and keep all user settings. /usr/local/* will not be touched in any case
when performing an upgrade.

How would I proceed with the reinstallation or should i try to upgrade to the latest version. Mine is 7.0 STABLE #4.

I tried your suggestions but nothing helped. Under sh, cat print the file but only the last bit is on screen... "more" does not work. I don't understand how I can see the whole file. vipw is not available in single user mode. So, I did a bit of deeper research on my problem and found the following. It seems to be quite nasty.

1. On boot up and just before the crash there were warnings of an "interrupt storm" whatever that may mean and then there are messages about bad file descriptor; and there is a WARNING / was not properly dismounted (obviously because of the hardware problem) and "init /bin/sh on /etc/rc terminated abnormally, going to single user mode....

2. on bootup, there is a warning - /etc/rc WARNING run_rc_command: cannot run /usr/sbin/inetd

3. for login : in openpam_load_module (): no pam_opie.so found

4. login: pam_start(): system error

5. fsck gets wrong superblocks and cannot fix anything

6. When in single user mode, cannot access /usr or /var

So, now I get the feeling that the installation is completely screwed. What I would like to recover is onle a bunch of files on the /usr partition like the web stuff for apache and some other files.

What are my options? is there a way I could access these files?

It is rather strange, or is it, that I have had problems with sata hdd connectors. In general I find that the connectors for the ps mouse and the sata connectors are rather mickey-mouse... they are often getting bad connections and without any intervention to the computer housing or innard... gremlins or strange vibrations?

Thanks for any further assistance.

Phil Jourdan

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to