Giorgos Keramidas wrote:
On Sun, 04 Jan 2009 11:48:36 -0500, Tim Kellers <timot...@wallnet.com> wrote:
I'm having a tussle with one of those things I've done a zillion times,
but now I can't fathom what the heck is wrong.

When I run flexbackup from a cron job (as root) , the following error is
returned by e-mail to root:

Errors:
mbuffer not found in $PATH
dump not found in $PATH
restore not found in $PATH

$PATH is set in root's  crontab: $PATH = "/sbin /bin /usr/sbin /usr/bin
/usr/games /usr/local/sbin /usr/local/bin"

You are not using `$PATH = xxx yyy' right?

Evaluating the variable to extract its _value_ needs a dollar sign, but
setting it should not use a dollar sign and the value elements should be
separated by ':' like this:

    PATH="/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin"



Pass the Pointy Hat over so I can strap it on twice. I had tried "/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin" but, yes I had the $ in front of PATH.

Wow, what a braincramp. I feel like a dope, but a dope that has his backup crons running, now.

Giorgios, THANK YOU!
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to