Peter Harrison wrote:
Wednesday, 31 December 2008 at  2:06:55 +0100, Per olof Ljungmark said:
Peter Harrison wrote:
Tuesday, 30 December 2008 at 23:49:23 +0100, Per olof Ljungmark said:

Hi all,

Here I am away with the family visiting friends and I REALLY need
to get the iwi if up and running.

It's a recently updated system (7.1RC2). Read the man pages, tried different variations on legal.intel_iwi.license_ack=1, iwi_load, firmware_load etc. in /boot/loader.conf but I cannot get a
connection to the router.

It used to work on this box with my basic config, a Thinkpad T42,
and it still does with XP.

The interface is associated to the access point ok.

Anyone who can hint me on how to debug this? Would sysctl
debug.iwi.0=1 help? Of course, ANY information is of interest. Does
iwi have a problem with certain routers?

Sorry, no config files, I'm without connectivity when booting

Any help appriciated!
I don't know whether iwi has issues with particular routers, however
I do have it working on 7-STABLE i386 without difficulty.

Does it help to see the relevant bits from my config?


if_iwi_load=YES wlan_load=YES firmware_load=YES iwi_bss_load=YES iwi_ibss_load=YES iwi_monitor_load=YES legal.intel_iwi.license_ack=1


ifconfig_iwi0="inet  netmask  ssid
***********  bssid 00:14:bf:94:1e:75  channel 11  wepmode on wepkey
****************************  deftxkey 1"

(yes, I know I shouldn't still be using WEP).

Works without difficult connecting to a Linksys router.

I did have some difficulty I seem to recall when I turned off SSID
broadcast on the router. I'd suggest trying with all the security
turned off if you haven't already to see if you can connect at all,
and then reintroduce the security measures later.
Thanks for your reply.

Your config is identical to mine. I think something fishy is going on
here but don't know what it is - yet..

The router is a Netgear WNR854T.

Have you tried running without WEP or WPA and with the router broadcasting the 
SSID, to test whether that's the issue?

Yes, did that. In all the cases I've tested iwi is associated but no IP. Several XP boxes works fine with same router and settings. A guess then would be that the problem lies with the routers DHCP server rather than the wireless.

Now back home, I tried same config with our Linksys router and no problem.

I could not find anything odd or unusual in the setup for the Netgear so why this happened is still obscure to me.

_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to