Steven Barre wrote:

I am new to bsd. I'm trying to upgrade from 6.3 Release to the latest stable 7.

I created the following csup file

*default base=/var/db
*default prefix=/usr
*default release=cvs tag=RELENG_7
*default delete use-rel-suffix
*default compress

I then used csup to get all the source files. I cd'd to /usr/scr and tried to run make buildworld and after 15-20 min get this error.

I have tried cleaning up with

# chflags -R noschg /usr/obj/usr
# rm -rf /usr/obj/usr
# cd /usr/src
# make cleandir
# make cleandir

Still I get the error.

mv -f term.h
cc -o make_keys -O2 -fno-strict-aliasing -pipe -I. -I/usr/obj/usr/src/lib/ncurses/ncurses/../ncurses -I/usr/src/lib/ncurses/ncurses/../ncurses -I/usr/src/lib/ncurses/ncurses/../ncurses -I/usr/src/lib/ncurses/ncurses/../../../contrib/ncurses/include -I/usr/src/lib/ncurses/ncurses/../../../contrib/ncurses/ncurses -Wall -DNDEBUG -DHAVE_CONFIG_H -DFREEBSD_NATIVE -DTERMIOS /usr/src/lib/ncurses/ncurses/../../../contrib/ncurses/ncurses/tinfo/make_keys.c
./make_keys keys.list > init_keytry.h
/libexec/ Shared object "" not found, required by "make_keys"
*** Error code 1

Stop in /usr/src/lib/ncurses/ncurses.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.
*** Error code 1

Stop in /usr/src.

# uname -a
FreeBSD 6.3-RELEASE FreeBSD 6.3-RELEASE #0: Wed Jan 16 04:18:52 UTC 2008 i386

Thanks in advance for your help._______________________________________________

csup is an excellent tool that cuts down the cruft of cvsup. But if I remember properly, there is a path to follow when upgrading from a older release to a newer release. simply getting the source and trying to build isn't it.

Going from memory, I heard you have to upgrade to the latest subrelease of your current major release (6.4 in your case). From 6.4, you have to upgrade to 7.0. then from 7.0, you can upgrade to RELENG_7

You might want to do one of the following, because it will probably be quicker: 1) Backup everything. Stick in the latest snapshot CD and install (or maybe upgrading) from that, then restoring. 2) Trying freebsd-update to upgrade you to that big jump. I've never tried upgrading such a large jump, and i would have a backup just in case.

I hope you find the right path, the error you pasted is saying it's not finding a RELENG_7 library due to the fact that your running system is a RELENG_6

Good luck.  post if you have more questions.

Tim Judd

I will top-post when I feel like it. For those who are so demanding everyone bottom-post,
  You'll just have to forgive others when they choose to top-post.
_______________________________________________ mailing list
To unsubscribe, send any mail to ""

Reply via email to