On Fri, 23 Jan 2009 12:32:39 Ian wrote:
> Hi,
> I've started upgrading a machine from 7.0 to 7.1 using freebsd-update. It's
> the first time I've upgraded to a new os version with it (always used
> cvsup/ make world & mergemaster before).
> All was going well until it came to merging the new & old conf files. I
> wasn't quite sure what to do when asked to edit some of the files (it's not
> the same as mergemaster), so I did what I thought was best (having made a
> backup of /etc first!)
> Anyway, once that was finished, it then showed me the resulting merged
> files and asked if each one looked reasonable. I answered yes to the first
> one, but with the second file wasn't right, so I answered no - assuming it
> would give me the chance to edit the file again (like mergemaster does).
> Instead it just dumped me back at the command prompt with no indication as
> to how to proceed from there.
> I tried running the freebsd-update install command again, but it said no
> updates are available to install, run freebsd-update fetch first.
> Is there some way I can resume the upgrade process? Or do I need to do a
> rollback and then fetch & update again?
> Cheers,

Well I ended up doing a rollback and then ran the update again. It didn't try 
to download all the updates again, just installed them again, so it wasn't so 
painful. Now I understand how to use the conf file merging part, it's all 
very easy and seems to have worked correctly - very nice!

gpg key: http://home.swiftdsl.com.au/~imoore/no-spam.asc

Attachment: signature.asc
Description: This is a digitally signed message part.

Reply via email to