On Fri, Apr 17, 2009 at 06:27:19AM -0500, Derek Ragona wrote:
> At 03:15 PM 4/15/2009, Bob Willcox wrote:
> >I asked this question in freebsd-ports (in a different way as I thought
> >maybe I could clarify the situation some by rewording it) the other day
> >and didn't receive any reply so I thought I try here this time.
> >
> >I have a 7.2-prelease system that I am trying to get sendmail and
> >MailScanner running on and for some reason sendmail isn't listening on
> >*.smtp, though it is listening on localhost.smtp.
> >
> >If I remove MailScanner from the mix and run sendmail in the
> >conventional way (with sendmail_enable="YES" specified in /etc/rc.conf)
> >then things work as expected (except no MailScanner, of course).
> >
> >I currently have a running 6.4-stable system that this new 7.2 system
> >is scheduled to replace that is using the same MailScanner and sendmail
> >configuration files and it is working ok (and has been for a long time).
> >
> >I suspect that I'm simply missing some configuration option here that
> >I've overlooked or that may have changed between 6.4 and 7.2, but don't
> >really know where to look.
> >
> >Any help or tips on things to do/check would be greatly appreciated.
> >
> >Thanks,
> >Bob
> >
> >--
> >Bob Willcox              The trouble with doing something right the first
> >b...@immure.com           time is that nobody appreciates how difficult it 
> >was.
> >Austin, TX                     -- unknown
> 
> Bob,
> 
> 
> I have sendmail with mailscanner running on 7.1 release with no 
> problems.  Do you have:
> mta_type="sendmail"
> mailscanner_enable="YES"
> in your /etc/rc.conf?
> 
> I also have:
> spamd_enable="YES"
> in my /etc/rc.conf
> 
>          -Derek

Thanks Derek. Your reply gave the clues that I needed to make further
progress on this problem. I now have sendmail listening on *.smtp. I had
to also add the lines:

mta_enable="YES"
mta_flags="-bd"

to my rc.conf file so that the /usr/loca/etc/rc.d/mta script would run
and have the right flags for sendmail. Without the -bd flag sendmail
would print out a message about needing recipients and then just hang
there at startup.

I still don't understand what may have changed between 6.x and 7.x. (I
have none of the mta_* variables specified in my 6.4 system's rc.conf.)

Thanks again,
Bob

> 
> -- 
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
> 

-- 
Bob Willcox              The trouble with doing something right the first
b...@immure.com           time is that nobody appreciates how difficult it was.
Austin, TX                     -- unknown
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "freebsd-questions-unsubscr...@freebsd.org"

Reply via email to