I got it fixed (or atleast, as good as it can be fixed)

For future reference, here's what went wrong.

During the weekend, SAIX upgraded and repaired all Cisco equipment on their 
network. During this repair, they somehow managed to break something major. 
The /etc/ppp/options file on the offending BSD box contained the asyncmap 0 
option. This tells pppd not to escape characters leaving as part of packets 
that could be misunderstood as being controle characters by the other side.

This has been woking fine for a long time. however, during SAIX's tinkering, 
they managed to get their PPP gateways to not ignore controle characters 
coming in as part of IP packets, as they should be doing.

What was going wrong was that some part of the DNS query must have been seen 
as some arb. controle character. The machine then handled the packet 
incorrectly, and it never reached the NS it was meant for.

To fix this, just remove asyncmap 0 from your config file. This gives a 
slight performance hit, but with the wonderful resourcefullness of some 
ISPs, what can you do...

Origional message follows:

This gets a 10.0 on my weird-o-meter.

I have a FreeBSD 4.7-RELEASE machine sitting at a client which dials in and 
collects their mail via POP3, and sends outgoing mail via a smarthost which 
points to an SMTP server at their ISP.

This machine has worked fine since late last year, but started giving a 
strange problem this week.

When connected to their ISP, SAIX, the machine can ping any live internet IP 
and it can traceroute to anywhere, but, it can not talk to any DNS server. 
Any traffic to port 53 UDP simply seems to dissapear.

The same with firewalling enabled as normal, or even with ipfw add 1 allow 
ip from any to any

When connected to any other ISP we have tried dialing, all works perfectly. 
When dialed from another FreeBSD box with the same username/password, the 
SAIX connection works perfectly.

Yet, this single machine absolutely flat out refuses to talk to any name 
server while connected to SAIX, firewalling, no firewalling, no difference.

I have tried running tcpdump -i ppp0 udp port 53 in an attempt at capturing 
these packets, nothing, I also looked at rl0 just for interest's sake, 

I have run out of ideas, what am I missing?

PS: Please CC me in the reply, I get so much list mail I might miss a reply 
Willie Viljoen
Freelance IT Consultant

214 Paul Kruger Avenue, Universitas
South Africa

+27 51 522 15 60
+27 82 404 03 27 (mobile)

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to