Yeah I ran into that yesterday myself.  The mysql_install_db doesnt leave
you with a working mysql database lately.  What did to fix it was mysqld
-u mysql --skip-grant &

(Im assuming you have your mysql firewalled off, if not do that first ;)

At that point mysql is up enough to restore the mysql database.  I ran
msyql mysql < mysql.sql where mysql.sql was made from mysqldump of a
working mysql. Then mysqladmin shutdown.  Then your fine after that for
normal operations.

I am using innodb as the default table type.  I dont know if you are or
if that matters.

On Fri, 29 Aug 2003 02:52:56 -0400, "Ben Dover"
>    I managed to mess up my MYSQL4.1 on my 5.1 box and I can't seem to get
>    it 
> straightened out.  I think the best way to resolve this would be to do a 
> fresh install of MYSQL server.  I did a pkg_delete of MYSQL-server and 
> client and installed again from ports but I'm getting the same error 
> messages.  Is there a way to just start out fresh like I never had MYSQL 
> installed in the first place? The error I'm getting is:
> 030829  2:36:36  Fatal error: Can't open privilege tables: Can't find
> file: 
> './mysql/host.frm' (errno: 13)
> 030829 02:36:36  mysqld ended
> This started out from something I did while trying to get Plesk6 to work
> on 
> 5.1 (which I did) but without MYSQL working I uninstalled Plesk6. I think 
> what I did was delete the database mysql and I guess it is essential. 
> Any 
> assistance would be appreciated but I'm leaning toward a fresh install if 
> possible.
> _________________________________________________________________
> MSN 8: Get 6 months for $9.95/month.
> _______________________________________________
> [EMAIL PROTECTED] mailing list
> To unsubscribe, send any mail to
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to