> >with vinum
> >
> ># newfs /dev/vinum/vinum0
> >/dev/vinum/vinum0: 1085915.5MB (2223954992 sectors) block size 16384,
> >fragment size 2048
> >          using 5910 cylinder groups of 183.77MB, 11761 blks, 23552 inodes.
> >newfs: can't read old UFS1 superblock: read error from block device:
> >Invalid arguement
> Try newfs -O 2 /dev/vinum/vinum0 to force ufs2. Hope that works.

Nope, I've tried that and a ton of other options. I've looked into that
"can't read old UFS1 superblock error" but its not actually trying to
write UFS1, it looks like (someone feel free to correct me if i'm wrong)
that its trying to zero out the old UFS1 blocks so older versions of
fsck don't mistaken the filesystem for UFS1, try and repair it, and
therefore break it. I think it errors out for the same reason, it can't
access the drive like the second error.

For kick's (like i said i've tried alot of things) i took out that part
of the code, planning on just being careful :), and that error went away
but i still got the read error from superblock device: Invalid

Someone else commented there should be a "-v", but the option seems to
have been removed in 5.1 (5.x?), newfs can figure it out without being told,
and does work fine with vinum when its not more than a terabyte.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to