On Oct 22, 2003, at 4:00 PM, Dave McCammon wrote:



--- Ryan Sandridge <[EMAIL PROTECTED]> wrote:
Hello all.  I decided it was time to start doing
backups.  On Oct 7th,
I did a full dump of /usr filesystem (among others),
as such:
# dump -0uan -f - /usr | gzip -7 >
/tmp/20031007-usr-lvl0.dump.gz

This seemed to work as expected, here is some info
about the gz file:
% gzip -l 20031007-usr-lvl0.dump.gz
compressed  uncompr. ratio uncompressed_name
507027476 1590855680  68.1% 20031007-usr-lvl0.dump

Everything so far so good.  Today (Oct 22) I tried
an incremental dump,
as such:
# dump -5uan -f - /usr | gzip -7 >
/tmp/20031022-usr-lvl5.dump.gz

Here is where I start getting confused.  While my
other incremental
backups today (/ and /var), seemed to be fine, the
/usr dump was huge.
Here is info about the gz file:
% gzip -l 20031022-usr-lvl5.dump.gz
compressed  uncompr. ratio uncompressed_name
527112624 543600640   3.0% 20031022-usr-lvl5.dump

This incremental backup is larger than the original
full dump.  Also
notice that the compression ratio was 3.0%.  When
examining the list of
files dumped, I don't see anything that could lead
to a file size like
this.  A rough count shows that the backup should
have been roughly
11MB uncompressed, compared to the 518MB
uncompressed.  I've tried
reading up on both dump and gzip, but haven't found
a clue.  Perhaps
I've discovered dark matter.

Thanks,
   Ryan

Where is the file of your first backup stored? Did it get backed up as part of the incremental backup?

I should have mentioned that I had checked that already, because that would almost explain the unaccounted for 507 MB... but unless I'm missing something, that is not the problem. The backups were made onto /tmp filesystem, which were then archived to cd-rom, and deleted from /tmp. Ah, might be onto something though... I made an .iso file containing the dumps, which was copied to my home directory before burning to cd. That .iso file sat there until today, but was deleted before I did today's dump. So, I suppose it is possible that the filesystem wasn't flushed (is that what its called?), so the file was still there. I presume, however, this would be a bug with dump, as that .iso file is NOT in the archive.


Do you think this is what happened?

Thanks,
  Ryan

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to