On Wed, Oct 22, 2003 at 10:01:51PM -0400, Ryan Sandridge wrote:
> Well, as a newbie, it only took me about 10 hours to figure out on my 
> own that I needed to run fsck.  It showed me that I had an unreferenced 
> file hiding on my disk; however fsck never seemed to work as 
> documented.  I couldn't ever run it with 'fsck -p', I always received 
> (and still do receive):
> 
> /dev/ad0s1g: NO WRITE ACCESS
> /dev/ad0s1g: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
> 
> and when I ran it with just 'fsck', it would always answer "no" to the 
> prompts to fix the problems without giving me an opportunity to fix it. 
>  No I didn't use the -n flag to force no responses, and I am aware of 
> the -y flag, but the documentation warns against doing this.  Finally I 
> threw my hands up, and rebooted, which seemed to clear up the 
> unreferenced file.

You should only be running fsck on unmounted filesystems, or those mounted
read-only.  Looks like you tried to fsck a mounted filesystem?

Cheers,

        Scott

-- 
===========================================================================
Scott Mitchell           | PGP Key ID | "Eagles may soar, but weasels
Cambridge, England       | 0x54B171B9 |  don't get sucked into jet engines"
scott at fishballoon.org | 0xAA775B8B |      -- Anon
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to