This has happened to me 3-5 times so far, in the past two months. The ttyvs are all black, the monitor acts as though it gets no signal... kind of. Specifically, the monitor will power down the screen after a bit, as normal. However, instead of the light blinking on 1 second intervals or so, it will hardly blink -- almost looking solid, but having an ever so slight point where the led is off. I've never seen such a thing before.

As for how it got this way, I'm not quite sure. This time, I plugged my USB drive, went to mount, invalid superblock.. ok, fsck it.

[~]$ fsck /dev/da0"
** /dev/da0
** Phase 1 - Read and Compare FATs

hard drive reads for a considerable time (60g on usb 1.1 -- the adapter, not the enclosure). In the end,

(repeat the line below in this space, thousands of times perhaps)
swap_pager_getswapspace: failed
pid 9907 (fsck_msdosfs), uid 0, was killed: out of swap space

So now, as you can see, the da0 device is a msdosfs. There are no slices or anything else on the disk.. I created one when I made it, but it didn't show up in /dev and I was told to use da0. So I did. Works relatively well, I might add... though I somehow think it won't work so well on windows. But that's another topic.

So, at this point fsck has just died, being out of swap space (192 physical + 384 swap). Arright.. mount.. it worked before, why not this time? "Invalid super block." ... ah well. Worth a shot.

fsck /dev/da0
** /dev/da0
** Phase 1 - Read and Compare FATs

*disk reads for a while, stops reading and the computer starts chunking away on the local hard drive. After a bit, it resumes reading from the USB drive*

Now the fun stuff. The first time I only lost a mozilla session and abiword, being out of swap space. This time, it all goes out.. I'm still in X (where I've been doing this all from -- 1 xchat, 2 xterms, and acroread were all that were left running). Problem is, my mouse isn't moving, no keyboard response. So I ctrl-alt-F2 to the terminal I launched x from -- black. Nothing. alt F3, nothing. Alt F9, beep, no X.. so I go back to ttyv1, "startx" and x comes hopping right along. Moral of this paragraph, the consoles are still responsive, I just can't SEE them. The monitor acts somewhere in between "I'm getting a signal" and "I'm not getting a signal."

At this point, I'm rather out of ideas. I've not rebooted yet as there's no real need. I know the consoles were working immediately before fsck took out my X as I was doing fsck from ttyv2 as root, rather than sudo. (all the fsck cmds above were sudo, pretty much). It had the same thing as root; run out of swap space.

things to note:
the file system is fat32; fdisk -s /dev/da0:
/dev/da0: 7296 cyl 255 hd 63 sec
Part        Start        Size Type Flags
nothing more. fdisk by itself says all partitions are unused.

I've never managed to completely fsck this file system; however, mount -t msdosfs /dev/da0 /mnt/USB does allow me to mount and use it. Not using -t will give me invalid superblock ;-) Howver, I believe ripping the USB cable out before unmounting has given me errors on the drive that fsck has fixed -- it just dies, I go to mount and it works.

my kernel config is, in case you want any info about it or to see if I have any debug support built in (you'll have to tell me step-by-step if you want something done, as I've never used it before nor have I seen/found instructions), at:
http://w3.uwyo.edu/~ablair/DrkAthlon.conf (copied, pasted, verified. On another note, if you can POSSIBLY not, do not attend this uni. Or if you must, avoid the dorms at all cost, unless you like the thought of the internet consisting of only WWW.*)


uname -a:
FreeBSD DrkAthlon 5.1-RELEASE-p10 FreeBSD 5.1-RELEASE-p10 #0: Mon Oct 20 20:30:08 MDT 2003 [EMAIL PROTECTED]:/usr/home/obj/usr/home/src/sys/DrkAthlon i386


last cvsupped approximately... 10/20/03

As for the previous times this has happened, I don't remember what I was doing. It could have been this, it is also possible it wasn't.

Any more info wanted/needed, let me know. Same goes for clarification. I tried to incude all I could, but who knows.

As for my intent: I want a way to get my consoles back without rebooting. If I can pin down a bug for anyone, all the better -- I'm pretty flexible in time, uptime, stability, etc etc.

And last, thanks for any help.

-DrkShadow
lightmoogle
at
hotmail
dot
com

_________________________________________________________________
Want to check if your PC is virus-infected? Get a FREE computer virus scan online from McAfee. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to