"W. Sierke" wrote:
> More guessing (as I'm still not clear on the specifics of what is
> failing)...
> Is sendmail running as user:smmsp when it's calling maildrop? That would
> explain why maildrop isn't able to change itself to user:vmail, no? Should
> setting the setuid bit circumvent this? When I try that I get:
> Dec 26 15:08:20 maildrop[93442]: You are not a trusted user.
> where I guess "You" = smmsp?
> If this is the case, then it must be a problem for any program run from
> /etc/mail/aliases, is this just too hard to do on a default FreeBSD? Still
> out of my depth here but learning a bit more. :)

I'm curious about the lack of response since I was thinking there was a good
chance this would be a fairly obvious one for our more experienced players.
Am I wrong in thinking that this is just a permissions/security issue? Just
to recap: I'm trying to run maildrop from /etc/mail/aliases with the
following entry:

second-domain-tld:    "|/usr/local/bin/maildrop -d [EMAIL PROTECTED]"

where second-domain-tld is from an entry in virtusertable.

Initially this gave me:

Dec 25 17:05:19 maildrop[75657]: Cannot set my user or group id.

so as per the above included text, I tried making maildrop setuid:

Dec 26 15:08:20 maildrop[93442]: You are not a trusted user.

Any and all hints, suggestions, advice and abuse welcome as all my research
efforts are getting me nowhere at the moment.


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to