On Sun, Jan 04, 2004 at 08:50:23AM -0500, Marius Kirschner wrote:

> So I tried to build the standalone ImageMagick
> (/usr/ports/graphics/ImageMagick), but after playing around with it for 2
> hours I keep getting the following error:
> 
> jp2.c:778: `JAS_IMAGE_CT_OPACITY' undeclared (first use in this function)
> gmake[1]: *** [jp2.lo] Error 1
> gmake[1]: Leaving directory
> `/usr/ports/graphics/ImageMagick/work/ImageMagick-5.5.7/coders'
> gmake: *** [all-recursive] Error 1
> *** Error code 2
> 
> Stop in /usr/ports/graphics/ImageMagick.
> 
> And I already have netpbm installed, but one application makes use of
> ImageMagick (or imagick) and while it is not critical to get it to work it
> would be nice. :)

Make sure your graphics/jasper port is up-to-date? Or if you don't
care about JPEG2000 support, add -DWITHOUT_IMAGEMAGICK_JPEG2000 to
your make flags.

Dunno really, because installing it worked perfectly well for me.

        Cheers,

        Matthew

-- 
Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to