Hi Dany,

 I think I can workaround my problem by manually installing the required
packages and the openoffice: my main issue is to understand if I
really hit a limit of pkg_add or not, as I assumed, by reading docs
& posts, that it should be able to resolve dependencies and automatically
download the required packages.

 I suppose it works (not tested) if the package one wants to install
is located remotely, and on the same site where all other required
packages can be found. This is just my conclusion based on what I've
seen, but I'm looking for some expert to confirm or contradict it.

Thanks anyway for your offer :)

Ciao, Luca

Dany wrote:
I got OpenOffice working on my 5.2 with the help of a gentleman for the bsdforums who sent me a newer version compiled for 5.2RC2.

I didn't want to compile it by myself (time consuming) so it was kind of him to make this available. Worked right out of the box.

If you want I can post the file on my webserver so you can download it. Just say the word.


Luca Gerli wrote:

Hello all,

 I'm totally new to FreeBSD, and I come from a Linux-Gentoo experience.
I installed 5.2RC2 yesterday without much hassle, but I'm having problems
installing OpenOffice.org v1.1 package, due to some dependency errors
coming from pkg_add that I couldn't solve either looking at the docs
or skimming through past posts.

So, I downloaded the FreeBSD package from:


 First thing I tried was to run pkg_add on the downloaded package,
which failed due to some dependency errors:

 falcon# pkg_add ./openoffice-1.1.0_1.tbz
 pkg_add: could not find package glib-1.2.10_10 !
 pkg_add: could not find package gtk-1.2.10_10 !
 pkg_add: could not find package ORBit-0.5.17 !

 Then I tried the "-r" option, hoping the command would automatically
download the missing and necessary packages, without much luck as
pkg_add refused to use the local ./openoffice-1.1.0_1.tbz, and was
looking for it on ftp.freebsd...:

 falcon# pkg_add -r ./openoffice-1.1.0_1.tbz
 Error: FTP Unable to get ftp://ftp.freebsd.org/pub/FreeBSD/ports/
  i386/packages-current/Latest/./openoffice-1.1.0_1.tbz: File
  unavailable (e.g., file not found, no access)
 pkg_add: unable to fetch 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/
  i386/packages-current/Latest/./openoffice-1.1.0_1.tbz' by URL

I then set the PACKAGESITE to the appropriate link to download openoffice,
but then this same site was used to download the missing packages which
were obviously not found.

 falcon# setenv PACKAGESITE http://projects.imp.ch/openoffice/current/
 falcon# pkg_add -r ./openoffice-1.1.0_1.tbz

I'm surely doing something wrong, but my questions are:

 . is there a way to specify more than one FTP/HTTP source for
   packages ? PACKAGESITE does not seem to accept a syntax where
   different URLs are separated by a semicolon (":");

 . do I have to manually download the necessary packages that
   openoffice depends on ? Or is pkg_add really able to do that alone ?

Thanks for any help / documentation pointers you might give,

 Best regards,

_______________________________________________ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-questions To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to