Can you just paste dmesg -a?


--G. Held ----------------------

Copyright (c) 1992-2003 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 5.2-RC2 #0: Mon Dec 22 07:23:48 GMT 2003
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC
Preloaded elf kernel "/boot/kernel/kernel" at 0xc09e1000.
mptable_probe: MP Config Table has bad signature: Mou
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: AMD Athlon(tm)  (1094.15-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x6a0  Stepping = 0

AMD Features=0xc0400000<AMIE,DSP,3DNow!>
real memory = 536805376 (511 MB)
avail memory = 511774720 (488 MB)
Pentium Pro MTRR support enabled
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcibios: BIOS version 2.10
Using $PIR table, 16 entries at 0xc00fde60
pcib0: <Host to PCI bridge> at pcibus 0 on motherboard
pci0: <PCI bus> on pcib0
agp0: <NVIDIA nForce2 AGP Controller> mem 0xe0000000-0xe3ffffff at device 0.0 on pci0
pci0: <memory, RAM> at device 0.1 (no driver attached)
pci0: <memory, RAM> at device 0.2 (no driver attached)
pci0: <memory, RAM> at device 0.3 (no driver attached)
pci0: <memory, RAM> at device 0.4 (no driver attached)
pci0: <memory, RAM> at device 0.5 (no driver attached)
isab0: <PCI-ISA bridge> at device 1.0 on pci0
isa0: <ISA bus> on isab0
pci0: <serial bus, SMBus> at device 1.1 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xeb003000-0xeb003fff irq 5 at device 2.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <OHCI (generic) USB controller> on ohci0
usb0: USB revision 1.0
uhub0: (0x10de) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
ohci1: <OHCI (generic) USB controller> mem 0xeb004000-0xeb004fff irq 11 at device 2.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <OHCI (generic) USB controller> on ohci1
usb1: USB revision 1.0
uhub1: (0x10de) OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 3 ports with 3 removable, self powered
pci0: <serial bus, USB> at device 2.2 (no driver attached)
pci0: <network, ethernet> at device 4.0 (no driver attached)
pci0: <multimedia, audio> at device 6.0 (no driver attached)
pcib1: <PCIBIOS PCI-PCI bridge> at device 8.0 on pci0
pci1: <PCI bus> on pcib1
pci_cfgintr: 1:7 INTA BIOS irq 5
pci_cfgintr: 1:9 INTA BIOS irq 11
pci_cfgintr: 1:10 INTA BIOS irq 11
pci1: <network, ethernet> at device 7.0 (no driver attached)
rl0: <D-Link DFE-530TX+ 10/100BaseTX> port 0xc000-0xc0ff mem 0xea010000-0xea0100ff irq 11 at device 9.0 on pci1
rl0: Ethernet address: 00:40:05:85:ee:cc
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> on miibus0
rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ahc0: <Adaptec aic7850 SCSI adapter> port 0xc400-0xc4ff mem 0xea011000-0xea011fff irq 11 at device 10.0 on pci1
ahc0: Host Adapter Bios disabled. Using default SCSI device parameters
aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs
atapci0: <nVidia nForce2 UDMA133 controller> port 0xf000-0xf00f at device 9.0 on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
pcib2: <PCI-PCI bridge> at device 30.0 on pci0
pci2: <PCI bus> on pcib2
pci_cfgintr: 0:30 INTA routed to irq 11
pcib2: slot 0 INTA is routed to irq 11
pci2: <display, VGA> at device 0.0 (no driver attached)
orm0: <Option ROMs> at iomem 0xd4000-0xd57ff,0xd0000-0xd3fff,0xc0000-0xcefff on isa0
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x64,0x60 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse, device ID 3
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> at port 0x3f7,0x3f0-0x3f5 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1 at port 0x2f8-0x2ff irq 3 on isa0
sio1: type 16550A
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
unknown: <PNP0303> can't assign resources (port)
unknown: <PNP0f13> can't assign resources (irq)
unknown: <PNP0501> can't assign resources (port)
unknown: <PNP0700> can't assign resources (port)
unknown: <PNP0400> can't assign resources (port)
unknown: <PNP0501> can't assign resources (port)
Timecounter "TSC" frequency 1094147174 Hz quality 800
Timecounters tick every 10.000 msec
GEOM: create disk ad0 dp=0xc48ef660
ad0: 29311MB <Maxtor 93073U6> [59554/16/63] at ata0-master UDMA66
acd0: CDROM <TOSHIBA CD-ROM XM-5602B> at ata1-master PIO3
Waiting 15 seconds for SCSI devices to settle
Mounting root from ufs:/dev/ad0s1a
ath0: <Atheros 5212> mem 0xea000000-0xea00ffff irq 5 at device 7.0 on pci1
ath0: mac 5.6 phy 4.1 5ghz radio 1.7 2ghz radio 2.3
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: 802.11 address: 00:0d:88:8b:d2:c7

-----Original Message----- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of G. Held Sent: Monday, January 05, 2004 5:07 PM To: [EMAIL PROTECTED] Subject: Wireless PCI card setup


I have a D-Link DWL-G520 PCI card that I am trying to install, with
less success than I would like.

I am using FreeBSD 5.2-RC2.  I have been able to bring the card up
manually with ifconfig for an Atheros chipset ("ifconfig ath0 inet netmask") and doing so, I can see the
.html setup screens for my router (D-Link Di-624 (
there is a connection.  However, there I am stopped.  I cannot get
past the wireless router to my other machines (hooked into a Linksys
Cable/DSL router ( or the Internet in general.  No
http, no pings, nada.

I'm led to believe that the fault is with my setup of the wireless
card.  If I hook the machine into one of the wireless router's rj45
jacks, the connection is just fine.  The wireless card also
functioned without problems in a short-lived win98 install.  So the
card works, and the router setup seems to be good.  That leaves the
card setup within FreeBSD.

I am at a loss as to what to try next.  I've tried DHCP, I've tried
setting up a network interface via sysinstall after bringing up the
ath0 whoozit with ifconfig (apparently the card is not detected at

What am I missing?

Any suggestions?  Relevant documentation you can direct me to?
Direct solutions?  :)

--G. Held -- End of line. _______________________________________________ [EMAIL PROTECTED] mailing list To unsubscribe, send any mail to "[EMAIL PROTECTED]"

End of line.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to