On Tue, 20 Jan 2004 11:42:28 -0500, Scott I. Remick wrote:

> Well crap, everything was going so well. I upgraded from 5.1 to 5.2 using
> cvsup, recompiled (nearly) all my ports (some KDE stuff is still
> complaining, but that shouldn't be relevant here). I have openssh installed
> via ports:
> su-2.05b# pkg_info | grep ssh
> openssh-3.6.1_5     OpenBSD's secure shell client and server (remote login
> prog
> And my /etc/rc.conf contains:
> sshd_enable="YES"
> sshd_program="/usr/local/sbin/sshd"
> Under 5.1, I'd SSH in (via PuTTY), then use port-forwarding to forward
> localhost:7001 to remote:5901. I could then run VNC, connect to
> localhost:7001, and tunnel my VNC session over SSH.
> Since upgrading to 5.2 (nothing else has changed), while I can still SSH
> in, attempting to tunnel VNC fails and I get the following error in my
> PuTTY log:
> 2004-01-20 11:34:21   Opening forwarded connection to localhost:5901
> 2004-01-20 11:34:22   Forwarded connection refused by server
> On the FreeBSD box, I see:
> Jan 20 11:33:57 scott sshd[78580]: error: getsockopt TCP_NODELAY:
> Connection reset by peer
> This is using the same configs, profiles, etc. Nothing has changed except
> the upgrade of the FreeBSD box from 5.1 to 5.2. Any thoughts?

Sorry to reply to my own post, but I'm still stuck and had more info to
offer. I've also tried adding the following line to my rc.conf:

sshd_flags="-f /usr/local/etc/ssh/sshd_config"

And in that sshd_config file, I added the following lines:

GatewayPorts yes

Although I'm not sure this applies. It's definitely using that config:

su-2.05b# ps -ax | grep sshd
  426  ??  Is     0:00.07 /usr/local/sbin/sshd -f
 1807  ??  Is     0:00.03 sshd: scott [priv] (sshd)
 1809  ??  R      0:00.07 sshd: [EMAIL PROTECTED] (sshd)

vncserver is definitely running:

su-2.05b# ps -ax | grep vnc
 1798  p0- S      0:00.23 Xvnc :1 -desktop X -httpd
/usr/X11R6/share/tightvnc/classes -auth /home/scott


su-2.05b# strobe -b 5900 -e 6000 localhost
strobe 1.05 (c) 1995-1999 Julian Assange <[EMAIL PROTECTED]>.
localhost  5901 unassigned   unknown
                -> RFB 003.003\n

I've also confirmed that I can VNC in using another PC on the local

But none of this has helped and I still get the error when I try to tunnel
VNC over ssh. 

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to