On Monday 08 March 2004 01:51 pm, Kris Kennaway wrote:
> On Mon, Mar 08, 2004 at 02:39:18PM +0100, Michael Sig Birkmose wrote:
> > Hi everyone,
> >
> > I recently tried to switch from compiling everything myself from
> > ports, to use portupgrade -PP package_name.
> >
> > However, after having run CVSUP on my ports tree, I run into the
> > problem, that the binary packages from ftp.something.freebsd.org
> > are far behind the version in the portstree.
> >
> > After a little bit of digging, I found out that
> > ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/i386/packages-5-current/
> > has much newer binary packages.
> >
> > However it stills is a bit behind?
> > What is the solution to this problem, or is there none? I would
> > really like to avoid compiling things...
>
> Since computers and mirror site bandwidth are still not infinitely
> fast, there will always be a time lag between the packages on the ftp
> site and the ports in the ports collection [1].  Unfortunately this
> means that you can't have it both ways: either you can compile the
> latest versions of all the ports yourself, or you can install
> packages that are a bit older.
>

The other side is that ports follows -current and -stable. It hasn't 
been that long since make on something like 4.8-release wouldn't build 
some ports. Would such a package install on the older systems?

People have had ways of building just make but that won't always work. 
Bison was also an example but I don't show any installed ports on my 
system that depend on bison-1.75_2. Of course, my pkg_info -R "$1" 
lookup command fails frequently.

Kent

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to