Problem:

I've lost my printer and I can't get it up!
The usb sybsystem have stopped to identify my MFD epson CX5200 usb
printer at all after I upgraded from 5.2-RELEASE (prior to
5.2.1-release) to CVS of 23. March FreeBSD 5.2-RELEASE.

Prior to this CVS upgrade the printer were identified as an
MFD printer (allthough only printing worked.)
Tested the printer on an Slackware and W2k system and both identify the
printer and print without any noticable problems. 
And yes, I've tested separate USB cables and USB ports on my
motherboard. ;)
I've tested the FreeBSD computers motherboard usb ports on an
usb storage device and they work flawless. (except the pesky
1.000MB/sec speed limitation.. oh well, that's another problem. :P )
Turning the printer on/off exites no response from usbd in the
sysconsole/syslog files.

Question:
Have there been done som changes in the usb / ulpt subsystem that have
caused this, and is there any reason for me to worry? ( Is it being
worked on?)
If not, is it recommend that I submit it to the Problem Report Database?


Running:
Uname -ar
FreeBSD x-ko 5.2-RELEASE FreeBSD 5.2-RELEASE #2: Tue Mar 23 23:49:08 CET
2004     [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC  i386

----------------
Dmesg log:

Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights
reserved. FreeBSD 5.2-RELEASE #2: Tue Mar 23 23:49:08 CET 2004
    [EMAIL PROTECTED]:/usr/obj/usr/src/sys/GENERIC
Preloaded elf kernel "/boot/kernel/kernel" at 0xc09fc000.
Preloaded userconfig_script "/boot/kernel.conf" at 0xc09fc1cc.
Preloaded elf module "/boot/kernel/linux.ko" at 0xc09fc21c.
Preloaded elf module "/boot/kernel/if_tap.ko" at 0xc09fc2c8.
Preloaded elf module "/boot/kernel/ipfw.ko" at 0xc09fc374.
Preloaded elf module "/boot/kernel/snd_via8233.ko" at 0xc09fc420.
Preloaded elf module "/boot/kernel/snd_pcm.ko" at 0xc09fc4d0.
Preloaded elf module "/boot/kernel/snd_via82c686.ko" at 0xc09fc57c.
Preloaded elf module "/boot/kernel/dummynet.ko" at 0xc09fc630.
Preloaded elf module "/boot/kernel/acpi.ko" at 0xc09fc6e0.
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: VIA C3 Samuel 2 (601.37-MHz 686-class CPU)
  Origin = "CentaurHauls"  Id = 0x673  Stepping = 3
  Features=0x803035<FPU,DE,TSC,MSR,MTRR,PGE,MMX>
real memory  = 234815488 (223 MB)
avail memory = 218525696 (208 MB)
npx0: [FAST]
npx0: <math processor> on motherboard
npx0: INT 16 interface
acpi0: <VT9174 AWRDACPI> on motherboard
pcibios: BIOS version 2.10
Using $PIR table, 7 entries at 0xc00fdeb0
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
acpi_cpu0: <CPU> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib0: slot 15 INTA is routed to irq 12
pcib0: slot 16 INTA is routed to irq 10
pcib0: slot 16 INTB is routed to irq 11
pcib0: slot 16 INTC is routed to irq 5
pcib0: slot 16 INTD is routed to irq 12
pcib0: slot 17 INTC is routed to irq 5
pcib0: slot 18 INTA is routed to irq 10
pcib0: slot 19 INTA is routed to irq 10
pcib0: slot 20 INTA is routed to irq 11
agp0: <VIA Generic host to PCI bridge> mem 0xe4000000-0xe5ffffff at
device 0.0 on pci0 pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib1: slot 0 INTA is routed to irq 10
pci1: <display, VGA> at device 0.0 (no driver attached)
vr0: <VIA VT6105 Rhine III 10/100BaseTX> port 0x9000-0x90ff mem
0xe9105000-0xe91050ff irq 12 at device 15.0 on pci0 vr0: Ethernet
address: 00:40:63:c9:da:14 miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
uhci0: <VIA 83C572 USB controller> port 0x9400-0x941f irq 10 at device
16.0 on pci0 usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0x9800-0x981f irq 11 at device
16.1 on pci0 usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0x9c00-0x9c1f irq 5 at device
16.2 on pci0 usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
pci0: <serial bus, USB> at device 16.3 (no driver attached)
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 8235 UDMA133 controller> port 0xa000-0xa00f at device 17.1
on pci0
ata0: at 0x1f0 irq 14 on atapci0
ata0: [MPSAFE]
ata1: at 0x170 irq 15 on atapci0
ata1: [MPSAFE]
pcm0: <VIA VT8235> port 0xa400-0xa4ff irq 5 at device 17.5 on pci0
pcm0: <VIA Technologies VIA1612A AC97 Codec>
vr1: <VIA VT6102 Rhine II 10/100BaseTX> port 0xa800-0xa8ff mem
0xe9107000-0xe91070ff irq 10 at device 18.0 on pci0 vr1: Ethernet
address: 00:40:63:c9:da:13 miibus1: <MII bus> on vr1
ukphy1: <Generic IEEE 802.3u media interface> on miibus1
ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: <Intel 82559 Pro/100 Ethernet> port 0xac00-0xac3f mem
0xe9000000-0xe90fffff,0xe9104000-0xe9104fff irq 10 at device 19.0 on
pci0 fxp0: Ethernet address 00:90:27:a2:86:9c
miibus2: <MII bus> on fxp0
inphy0: <i82555 10/100 media interface> on miibus2
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
atapci1: <Promise PDC20268 UDMA100 controller> port
0xc000-0xc00f,0xbc00-0xbc03,0xb800-0xb807,0xb400-0xb403,0xb000-0xb007
mem 0xe9100000-0xe9103fff irq 11 at device 20.0 on pci0 atapci1:
[MPSAFE] ata2: at 0xb000 on atapci1
ata2: [MPSAFE]
ata3: at 0xb800 on atapci1
ata3: [MPSAFE]
fdc0: <Enhanced floppy controller (i82077, NE72065 or clone)> port
0x3f7,0x3f0-0x3f5 irq 6 drq 2 on acpi0 sio0 port 0x3f8-0x3ff irq 4 on
acpi0 sio0: type 16550A, console
orm0: <Option ROMs> at iomem
0xd8000-0xd8fff,0xd0000-0xd7fff,0xc0000-0xcdfff on isa0 pmtimer0 on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x100>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on
isa0 Timecounter "TSC" frequency 601368280 Hz quality 800
Timecounters tick every 10.000 msec
ipfw2 initialized, divert disabled, rule-based forwarding enabled,
default to deny, logging disabled acpi_cpu: throttling enabled, 2 steps
(100% to 50.0%), currently 100.0% GEOM: create disk ad0 dp=0xc2700c60
ad0: 76319MB <ST380021A> [155061/16/63] at ata0-master UDMA100
GEOM: create disk ad1 dp=0xc2700860
ad1: 114473MB <ST3120026A> [232581/16/63] at ata0-slave UDMA100
GEOM: create disk ad2 dp=0xc2700260
ad2: 117246MB <Maxtor 4G120J6> [238216/16/63] at ata1-master UDMA133
GEOM: create disk ad3 dp=0xc26b1d60
ad3: 117246MB <Maxtor 4G120J6> [238216/16/63] at ata1-slave UDMA133
Mounting root from ufs:/dev/ad0s1a
IPv6 packet filtering initialized, logging disabled


-- 
"Throughout history it has been the inaction of those who could
have acted,  the indifference  of those  who should  have known
better,  the silence of the  voice of justice  when it mattered
most, that has made it possible for evil to triumph."
                                               - Haile Selassie
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to