Aleksander Rozman - Andy wrote:
Some time ago I did little experimenting on my FreeBSD box (I was trying to compile some programs and I installed new version of ceratain auto* and other programs) so after that I couldn't usee gcc anymore. I reinstalled gcc and some other tools, but now ncurses is of some older version.
I tried to reinstall ncurses and I succeed, but from is that dynamic library is not reinstalled along with other programs, which means that most of software on my computer is now unusable... How can I force ncurses to install dynamic library (I run install from contrib directory)...

In FreeBSD's base system you are not supposed to install anything directly from the 'contrib' tree, and neither from 'crypto'. 'libncurses', for instance, has to be built and installed from '/usr/src/lib/libncurses', like so:

  (clean up /usr/obj)
  make obj && make depend && make
  make install
  (clean up /usr/obj)

That's how it is in FreeBSD 4.x at least. Can't tell, though, whether the path names are still the same in 5.x.

Hope it works for you, too.

Uwe Doering         |  EscapeBox - Managed On-Demand UNIX Servers
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to