On Sun, Apr 11, 2004 at 11:01:51AM -0400, Rob wrote:
> When I try this, I get the error:
> m4: ../m4/cfhead.m4: No such file or directory
> So I looked for m4 and it appears to be in /usr/bin/
> so I run:
> %/usr/bin/m4 -D_CF_DIR=/usr/share/sendmail/cf/
> /usr/share/sendmail/cf/m4/cf.m4 freebsd.mc > foo.cf
> and get the same error.
> Is it telling me that m4 is not there or cfhead.m4 is missing. cfhead is
> located here:
> /usr/share/sendmail/cf/m4/cfhead.m4

It appears that the sendmail version you're trying to use is too old
for the required functionality using _CF_DIR to be present in the .m4

However, all is not lost.  You should be able to do:

    # cp foo.mc /usr/share/sendmail/cf/cf/
    # cd /usr/share/sendmail/cf/cf/
    # m4 ../m4/cf.m4 foo.mc > foo.cf
    # cp foo.cf /etc/mail

But like I said, upgrade as soon as you can.



Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to