--- Greg 'groggy' Lehey <[EMAIL PROTECTED]> wrote:
> > The error messages I'm seeing are...
> >
> > vinum: dataraid.p0.s1 is stale by force
> > vinum: dataraid.p0 is corrupt
> >
> OK, here your second subdisk has gone stale, meaning that updates
> have been missed.  There's every reason to believe that the data is
> inconsistent, but possibly it's nothing that an fsck couldn't gloss
> over.
> In this case, use "setstate":
>   # vinum setstate up dataraid.p0.s1  dataraid.p0
That worked, thanks.  If you don't mind, could you point me to some
documentation that explains a little more about what setstate does and

> Then do your fsck--if you want to be cautious, fsck -n in case
> something goes seriously wrong--and confirm that you can still access
> the file system on the volume.  If that's OK, do a
I can see the filesystem but thousands of files have problems.  I ran
fsck -y and the disk is marked clean and I could mount the filesystem. 

>   # vinum saveconfig
> Until you do the saveconfig, the changes you made with setstate are
> only in memory, and unless something else saves the state, they will
> be gone on reboot.
OK, that's done too.  Upon inspection alot of data is missing from the
filesystem.  No worries, I have a complete backup from 11 hours before
the crash.

Many thanks for your help Greg.


Do you Yahoo!?
SBC Yahoo! - Internet access at a great low price.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to