>>>>> Christian Hiris writes:

 > On Wednesday 02 June 2004 19:41, Jean-Marc Zucconi wrote:
 >> Is it supposed to work? I have properly mounted all required disks on
 >> the target machine and it failed first with 'touch: not found'. OK I
 >> copied touch in /tmp/install.$$ and tried again. Then it failed
 >> because it could not find install, then rpcgen. I copied them again in
 >> the temp dir, but now it can't go beyond the following:
 >> ===> lib/csu/i386-elf
 >> install -o root -g wheel -m 444  crt1.o crti.o crtn.o gcrt1.o /usr/lib
 >> install: crt1.o: No such file or directory
 >> Any ideas?
 >> Jean-Marc

 > It works fine for me. I use it for kernel, userland, ports and package 
 > installation. Builds from nfs client side work fine, too. Some points you can 
 > check:    

 > 1.
 > On your building machine: Does /usr/obj/usr/src/lib/csu/i386-elf/crt1.o exist? 

Yes of course (excepted that it is in fact /usr/obj/u4/src/lib/csu/i386-elf/crt1.o 
on both machines because of symlinks)

 > If not something went wrong with your "make buildworld".

No because 'make installworld' worked on the source machine.

 > On the target machine: Are kernel and the userland you try to install in sync? 

No but this should not matter since I upgrade from 4.9 to 4.10
(differences are minor) and the context was the same on the
source machine.

 > 2. 
 > From the FreeBSD Handbook: "All the machines in this build set need to 
 > mount /usr/obj and /usr/src from the same machine, and at the same point." 
 > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/small-lan.html

 > Are you sure both directory trees exported and mounted correctly?

Yes of course.

 > ie. my /etc/exports line on the nfs server looks like this:
 > /usr/obj /usr/src /usr/ports -maproot=0:0 -network -mask 

 > My corresponding /etc/fstab lines on the target host:
 >    /usr/ports      nfs     rw,-i,-s,-r=8192,-w=8192 0 0
 >      /usr/src        nfs     rw,-i,-s,-r=8192,-w=8192 0 0
 >              /usr/obj        nfs     
 > rw,-i,-s,-r=8192,-w=8192 0 0

 > 3.
 > Does nfs properly work? Some cheap low-end NICs possibly show a high packet 
 > retransmission rate and packet loss. This also can happen, if your nfs server 
 > is overloaded. You can check this with 'netstat -i -w 5', tcpdump or any 
 > other network sniffer. In this case tuning of your nfs mounts could help a 
 > little (man 8 mount_nfs). Try to play around with readsize and timeouts or 
 > try to use tcp instead of udp. 

This is not a NFS problem. If it was the case I would have noticed it
because the target machine also routinely mounts /usr/local and
/usr/X11 from the source machine.


Jean-Marc Zucconi -- PGP Key: finger [EMAIL PROTECTED] [KeyID: 400B38E9]
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to