Hi,

I am hoping someone can give us some clues about this problem.
A couple of us have done some searching, but found nothing that
bears directly on it.   Maybe some different search clues might
also help.   I am hoping for more than just "it won't work, because..."
but, even a conclusive one of those would get us off the point - which 
begins to dig in after a while...

Sorry this is rather long, but I wanted to include anything that 
might possibly be relevant.   Here goes.

One of our sites recently purchased a Dell Poweredge 400SC and
wants to run our school district network server system on it.   
Our system is currently based on FreeBSD 4.9 with some modifications 
to control the initial installation and aid in system management.     
We have it running on a number of other Dell Poweredge machines but 
not this particular model and especially not the LSIL SCSI controller.

It has a  2.4G Celeron CPU, 
          1 GB Memory
          Planar PE400SC, A/N, 2 Motherboard
          LSI Logics 53C1030 SCSI controller
          Fujitsu 36GB MAP337NP SCSI U320, 10K, 68 Pin connector hard drive.
          + NIC, IDE controller, CDROM, Tape drive, etc.

Although this model was not our recommendation, it would look like,
on paper, that it should at least, function.   But,,,

We cannot get any FreeBSD system to install on it, not ours or even
a straight FreeBSD 4.9 or 5.2.1 system - and I just tried 4.10 too with
the same result.   

It reads the CD, boots into the sysinstall or our install system just
fine.   It appears to do the fdisk and disklabel just fine.   Then it
hangs or appears to hang trying to do the newfs.   It puts out the message 
about writing superblocks and then nothing more comes out - no list
of superblocks of any kind, not even the first.

I have made up variations on our version of sysinstall with additional
messages but have not gotten any information that means anything to me.  

After a wait of several minutes it writes stuff to the ALT console.

If I let it set long enough (hours) it puts out a failed message.


I didn't have any MS install media handy, But did have my Partition Magic
"emergency" boot floppies around so I used them to take a look after
having attempted to do first our install, then FreeBSD 4.9 and finally 
FreeBSD 5.2.1.   

PM quite happily looked at things and recognized the FreeBSD slice (which, 
of course it called a partition).  So, I deleted the slice and created 
two and used the FreeBSD install CD to attempt to install on the second 
slice (da0s2) which it seemed happy to do.    After checking again with 
PM and seeing that the new slicing had the FreeBSD id one it I popped in 
another FreeBSD cd and sysinstall happily read up that label with all 
the FreeBSD partitions (a,b,e,f,g,h) that I had made.   So, FreeBSD can 
obviously write some part of the disk.   But, newfs still would get to 
writing superblocks and then nothing more happened.

That is the thing that seems odd to me.  It does write to some part of
the disk, enough to write label information.   But, it does not seem
to be able to do any other type of write to the disk.   So, are the
writes so different that a controller can handle one and not the other?
There are several LSIL SCSI controllers listed in the hardware list and
some in the 53Cnnnn series, but not exactly 53C1030.   Can the write be
enough similar to handle labels, but not other stuff?

One of the other people in our group put Linux on it - Debian I believe
 - and it appeared to install and write the disk just fine.  So, I take
that to mean that it isn't really just a flawed disk, though I suppose
that is still possible.

So, here is a blow-by-blow using any of the FreeBSD RELEASE cds I
happen to have handy (4.9. 5.2.1 and 4.10).

Basically, everything looks like it is going fine until after 
I select commit.   
It happily puts up a message on the curses screen saying

  "Making a new root filesystem on /dev/da0s1a"

Then it stops and appears to do no more - at least for a long time.

Here are the ALT-F2 console messages from when it starts to operate on
the disk:

|DEBUG: Scanning disk da0 for root filesystem
|DEBUG: Scanning disk da0 for swap filesystem
|Warning: Block size and bytes per inode restrict cylinders per group to 89
|
|/dev/da0s1a    1048576 Sectors in 256 Cylinders of 1 tracks, 4096 sectors
|          512,0 MG in 3 cylinder groups (89 c/g, 178.00 MG/g, 21632 i/g)
|
|Super-block backups   (for fsck -b #) at:
|
| ---- Here we get a long wait ----
|
|mpt1: time out on request index = 0xfe sequence=0x000000e8
|mpt1: Status 00000001; Mask 00000001; Doorbell 24000000
|request State on CHip
|SCSI IO  Request @ 0xc038b0b0
|         Chain Offset      0x10
|         Msg Flags         0x00
|         Msg Content       0x000000fe
|         Bus:                      0
|         TargetID                  0
|         Sense Buffer Length       32
|         LUN:                     0x0
|         Control           0x01000006  WRITE SIMPLEQ
|         Data Length       0x00010000
|         Sense Buf Addr    0x0004ade0
|         CDB[0:6]          0a 00 00 bf 80 00
|         SE32  0xd91c0c30: Addr=0xd123ae0 FlagsLength=0x14000520
|          HOST_TO_IOC
|         SE32  0xd91c0c38: Addr=0xcea4000 FlagsLength=0x94001000
|          HOST_TO_IOC LAST_ELEMENT
|         CE32  0xd91c0c40: Addr=0x4ac48  NxtChn0=0x16  Flgs=0x30 Lan=0x58
|         SE32  0xd91c0c48: Addr=0xd0c5000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c50: Addr=0xd126000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c58: Addr=0xd0c7000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c60: Addr=0xd0a8000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c68: Addr=0xd069000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c70: Addr=0xd08a000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c78: Addr=0xd12b000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c80: Addr=0xd0cc000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c88: Addr=0xd14d000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c90: Addr=0xd04e000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0c98: Addr=0xd0af000 FlagsLength=0x94001000
|          HOST_TO_IOC LAST_ELEMENT
|         CE32  0xd91c0ca0: Addr=0x4aca8  NxtChn0=0x0  Flgs=0x30 Len=0x20
|         SE32  0xd91c0ca8: Addr=0xd110000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0cb0: Addr=0xd0d1000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0cb8: Addr=0xd092000 FlagsLength=0x14001000
|          HOST_TO_IOC
|         SE32  0xd91c0cc0: Addr=0xcff3000 FlagsLength=0xd5000ae0
|          HOST_TO_IOC LAST_ELEMENT END_OF_BUFFER END_OF_LIST
 
Sometimes if I just let it set for a very long time, the curses screen
comes back with a message:

        Unable to make new root filesystem on /dev/da0s1a
        Command returned status 36

and the ALT-F2 screen gets a couple more messages added:

|write error: 128
|newfs: wtfs - writecombine - Input/output error


Is any of this enough information to do anything or get a driver
updated or something?

Any help will be appreciated,

Thanks,

////jerry

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to