On Tue, 6 Jul 2004, Rickard [ISO-8859-1] Borgmäster wrote:

atapci1: <VIA 8237 ATA133 controller> port 0xfc00-0xfc0f at device 15.1 on
pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
[...]
ad0: 156334MB <Maxtor 6Y160P0> [317632/16/63] at ata0-master UDMA133
ad4: DMA limited to UDMA33, non-ATA66 cable or device
ad4: 152627MB <ST3160023AS> [310101/16/63] at ata2-master UDMA33

How come FreeBSD kernel thinks my S-ATA disk is only capable of UDMA/33?

FreeBSD 4.x doesn't have specific support for the VIA 8237, and so doesn't properly realize that it should be able to do the faster DMA modes.


Next thing is that I today tried to move ~70GB of data from ad0
(ATA/UDMA133) to ad4 (S-ATA) disk. During the cp process I got these
messages:
Jul  5 15:13:18 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 390440063 of 195220000-195220255 (ad0s1 bn 390440063; cn 24303 tn 196
sn 20) trying PIO mode
Jul  5 15:13:18 <kern.crit> studsboll /kernel: ad0: DMA problem fallback
to PIO mode

My MSI motherboard with the same VIA 8237 does the same thing.

-CURRENT (5.x) does have support for SATA, and may (probably does) work with the 8237. (I haven't tried it on this motherboard.)

-Warren Block * Rapid City, South Dakota USA
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to