On Wednesday 07 July 2004 09:23 pm, Eric Crist wrote:
> Hey all,
> I posted almost a week ago about not being able to use my 16-bit
> PCMCIA Linksys WPC-11 v3 wifi card.  This card always worked well
> under 4.9, but I can't get it to work under 5.2.1.  The card is
> recognized, and I can even assign IP addresses and such, but it never
> associates to my wireless network, even if I set ssid, channel,
> media, etc, manually.  If I pull the card out, I get the following
> message in my logfile:
> wi0: wi_cmd: busy bit won't clear
> I'm at the point where I'm thinking of going back to 4.9 (well, 4.10
> now) so that I can use wifi again.  The only reason I went to 5.2.1
> was for better power management, but that doesn't really do anything
> for me anyways.
> If I can't get this to work within the next day or so, I'm going to
> just reinstall 4.x.
> Thanks for your help!
> Eric

How are you configuring the wireless card?

I'm using the same card on 5.2.1 Release on a Dell Inspiron 8100.  The 
only change I had to make to the scripts I used on FreeBSD 4.10 was to 

authmode "shared"

(I don't know why the change was needed since the wireless lan and 
access point stayed the same.)

Here's the contents of the script (I've changed the addresses and 

ifconfig wi0 inet netmask ssid "mywan" nwkey 
#(everything above should be on one line)
route add default
echo domain cablelynx.com > /etc/resolv.conf
echo nameserver >> /etc/resolv.conf
echo nameserver >> /etc/resolv.conf
echo wi0

If you try the script above and still get the error message, try adding 
the following to the beginning of the script so the script gets a clean 
start on the card:

ifconfig wi0 remove

Best of luck,

Andrew Gould
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to