Hi all.

I'm just getting my feet wet with using basic ACPI functionality. Up until my FreeBSD release and/or hardware only supported APM, so that's all I have used until now.

I have a Dell Precision 650n running RELEASE-5.2.1p9, and it seems that ACPI works as far as I can tell, but I'm not clear on how to use it correctly in all circumstances.

My first problem was that I could not do a power off (halt -p or shutdown now -p) -- ACPI would tell me that it could not do it then I would have to hit the power button or a key on the keyboard to reboot.

I solved this by adding "hw.acpi.disable_on_poweroff=0" to /etc/sysctl.conf. Now I can either type halt -p/shutdown now -p or just hit the power button on the Dell and FreeBSD will gracefully shutdown and power off.

Now I'm trying to get my arms around suspend functionality, and I'm not so clear as to the best way of suspending.

If I type 'zzz' (which appears to the equivelent of 'acpiconf -s 3'), the Dell does suspend, and the power button green LED blinks, which according the Dell manual, means the hardware thinks it is suspended. But I can't get it out of suspend. Pressing any key on the keyboard or mouse has no effect. If I press the power switch (which the Dell manual says should bring it out of suspend), then the system reboots.

I have also tried 'acpiconf -s 1', which seems to work better than s3. I can bring the system out of suspend by hitting the power button. However, when in suspend, the screen does not go blank. I can still see whatever was on the console, plus some output from acpiconf:
fwohci0: fwochi_pci_suspend

'acpiconf -s 1' also seems to work when I'm within X as well (using XFCE4). I can type 'acpiconf -s 1' from an xterm, and X will blank, return me to the console, and suspend -- but I can still see whatever is on the console. If I hit the power button (keyboard/mouse does not work), then I resume and X comes back to where it should be.

I have also tried '-s 4', and that just shuts down the whole computer.

I guess S1 would be fine for me suspending, but would S3 be better (if I can get it to resume correctly)? If S1 is all I can use, what can I do to blank the screen as well as suspend the system?

Any feedback would be greatly appreciated. Following is info I thought would be pertainent.

Duane Winner

System: Dell Precision 650n (option in BIOS to set power mgmt to S1 or S3)
FreeBSD: 5.2.1 p9

-su-2.05b# sysctl hw.acpi
hw.acpi.supported_sleep_state: S1 S3 S4 S5
hw.acpi.power_button_state: S5
hw.acpi.sleep_button_state: S1
hw.acpi.lid_switch_state: S1
hw.acpi.standby_state: S1
hw.acpi.suspend_state: S3
hw.acpi.sleep_delay: 5
hw.acpi.s4bios: 0
hw.acpi.verbose: 0
hw.acpi.disable_on_poweroff: 0
hw.acpi.reset_video: 1
hw.acpi.cpu.cx_supported: C1/0
hw.acpi.cpu.cx_lowest: 0
hw.acpi.cpu.cx_history: 96654/0

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to