hey hey,

anyone else willing to take a stab at this?  fwiw, i am fairly certain that
the problem resides somewhere between the keyboard and the chair, however
i would appreciate confirmation (i think :) before i do something silly
like submitting a pr or sending this off to another list.

(note that i had two very right suggestions to add the umass device,
however that didn't solve the problem, because i already had it compiled
into my kernel.  i simply forgot to include it in this message.  this has
been corrected below...)

apologies for the lengthy message.  really wanted to provide as much
useful info as i could.  thanks to all who suffer through the verbiage, yet
resolutely give it a go.


hello all,

for many moons now, i'll occasionally dedicate a dark day to getting my
USB Zip drive to work.  i've been through the handbook, faq, relevant man
pages, mailing lists and across the colossal googlesphere collecting bits
and pieces, none of which seem to get me the desired result.  i'm obviously
missing something.

i'm writing with the hope that, what i have managed to overlook will be so
obvious and straighforward, some kind reader will take 2 seconds to
point it out, so that i may zip off on my merry way.

### uname -a
FreeBSD 4.10-RELEASE-p1 i386

### relevant lines from kernel
device          vpo
device          scbus
device          da
device          umass
device          uhci    # uhci related entries show up in dmesg
device          usb
device          ugen

i have also tried with the ohci device added, but it never generates any
dmesg entries.  from what i gather, uhci and ohci have an 'either - or'
kind of relationship.  i'm supposing that uhci is the right device for my

now, when i boot with the zip device plugged in (whether or not there is a
disk loaded), the system will hang until i unplug the usb cable.

### dmesg
atapci0: <Intel PIIX4 ATA33 controller> port 0x1050-0x105f at device
7.1 on pci0 ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
uhci0: <Intel 82371AB/EB (PIIX4) USB controller> port 0x1060-0x107f irq 5
at device 7.2 on pci0 usb0: <Intel 82371AB/EB (PIIX4) USB controller> on
uhci0 usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
##-- hangs here for about 30 seconds, then chugs on happily --##
chip0: <Intel 82371AB Power management controller> port 0x1040-0x104f at
device 7.3 on pci0 pcm0: <ESS Technology Maestro-2E> port 0x1400-0x14ff irq
5 at device 8.0 on pci0
pccard: card inserted, slot 1
ad0: 17301MB <TOSHIBA MK1814GAV> [35152/16/63] at ata0-master UDMA33
acd0: CDROM <TOSHIBA CD-ROM XM-7002B> at ata1-master UDMA33
##-- hangs here *until* i pull the usb plug.  after i do, i get the
following error messages but the boot finishes nicely. --##
umass0: BBB reset failed, IOERROR
umass0: BBB reset failed, STALLED
umass0: BBB bulk-in clear stall failed, STALLED
umass0: BBB bulk-out clear stall failed, STALLED
umass0: BBB reset failed, STALLED
umass0: BBB bulk-in clear stall failed, STALLED
umass0: BBB bulk-out clear stall failed, STALLED
umass0: BBB reset failed, STALLED
umass0: BBB bulk-in clear stall failed, STALLED
umass0: BBB bulk-out clear stall failed, STALLED
Mounting root from ufs:/dev/ad0s2a
umass0: at uhub0 port 1 (addr 2) disconnected
umass0: detached

### /var/log/messages
Jul  4 21:47:04 /kernel: umass0: Iomega USB Zip 100, rev 1.00/1.00, addr 2
Jul  4 21:47:04 /kernel: umass0: Get Max Lun not supported (STALLED)
Jul  4 21:48:09 /kernel: umass0: BBB reset failed, IOERROR

### after booting, i plug the usb cable back in and usbdevs -v:
Controller /dev/usb0:
addr 1: full speed, self powered, config 1, UHCI root hub(0x0000),
Intel(0x0000), rev 1.00
port 1 addr 2: full speed, self powered, config 1, Zip 100(0x0001),
Iomega(0x059b), rev 1.00
port 2 powered

### ps auxw | grep -i usb
root 99  0.0  0.2   940  604  ?? Is 9:42PM 0:00.00     /usr/sbin/usbd
root  4  0.0  0.0     0    0  ??  DL    5:42PM  0:00.00  (usbtask)
root  3  0.0  0.0     0    0  ??  DL    5:42PM  0:00.00  (usb0)

looks good (i think).

### mounting
i'm not sure that i 'get' which device the zip maps to nor how to determine
this.  i have tried about 40 different combinations of mount (mostly
gleaned from my research), but i have yet to hit upon the right command. 

# mount -t msdos /dev/da* /mnt  # * = practically every single one
msdos: /dev/da0s4: Device not configured

...with the same results for /dev/sa* devices.

of the many combinations tried, /dev/usb0 has provided the most promising
error message (i think).

# mount -t msdos /dev/usb0 /mnt
msdos: /dev/usb0: Block device required

### final notes
1) not the drive - it works on several other non-*nix systems
2) not the usb port itself - boot to another OS and it works.
2) not the zip disks - have tried different disks all known to be good

if there is any further testing i can do or details i can provide, please
let me know.

many thanks,
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to